summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 10:52:25 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-14 10:52:25 +0000
commit1d033ac0215456dba1e49ceb1feb9bd58f227a93 (patch)
treea08b5cd60844ba6d37a49bcaaa64be37eb74f41c /media-libs/grilo
parentRevision bump. Fixes underlinking, bug 370025 by flameeyes; Adds alsa patches... (diff)
downloadgentoo-2-1d033ac0215456dba1e49ceb1feb9bd58f227a93.tar.gz
gentoo-2-1d033ac0215456dba1e49ceb1feb9bd58f227a93.tar.bz2
gentoo-2-1d033ac0215456dba1e49ceb1feb9bd58f227a93.zip
Bump to 0.1.16, bug 377651
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/ChangeLog10
-rw-r--r--media-libs/grilo/files/grilo-0.1.16-constants.py50
-rw-r--r--media-libs/grilo/files/grilo-0.1.16-fix-automagic-test-ui.patch32
-rw-r--r--media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch48
-rw-r--r--media-libs/grilo/grilo-0.1.16.ebuild83
5 files changed, 222 insertions, 1 deletions
diff --git a/media-libs/grilo/ChangeLog b/media-libs/grilo/ChangeLog
index 3165c16d2561..6d662427e9ec 100644
--- a/media-libs/grilo/ChangeLog
+++ b/media-libs/grilo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/grilo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.2 2011/06/15 16:37:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.3 2011/08/14 10:52:25 nirbheek Exp $
+
+*grilo-0.1.16 (14 Aug 2011)
+
+ 14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +grilo-0.1.16.ebuild,
+ +files/grilo-0.1.16-constants.py,
+ +files/grilo-0.1.16-fix-automagic-test-ui.patch,
+ +files/grilo-0.1.16-media-source-infinite-loop.patch:
+ Bump to 0.1.16, bug 377651
15 Jun 2011; Pacho Ramos <pacho@gentoo.org> grilo-0.1.15.ebuild:
Prepare to set 'xz' as default compressor for eapi4.
diff --git a/media-libs/grilo/files/grilo-0.1.16-constants.py b/media-libs/grilo/files/grilo-0.1.16-constants.py
new file mode 100644
index 000000000000..e8e26906a79f
--- /dev/null
+++ b/media-libs/grilo/files/grilo-0.1.16-constants.py
@@ -0,0 +1,50 @@
+KEY_NONEXISTING = 'nonexisting-key'
+KEY_ALBUM = 'album'
+KEY_ARTIST = 'artist'
+KEY_AUTHOR = 'author'
+KEY_BITRATE = 'bitrate'
+KEY_CERTIFICATE = 'certificate'
+KEY_CHILDCOUNT = 'childcount'
+KEY_DATE = 'date'
+KEY_DESCRIPTION = 'description'
+KEY_DURATION = 'duration'
+KEY_EXTERNAL_PLAYER = 'external-player'
+KEY_EXTERNAL_URL = 'external-url'
+KEY_FRAMERATE = 'framerate'
+KEY_GENRE = 'genre'
+KEY_HEIGHT = 'height'
+KEY_ID = 'id'
+KEY_LAST_PLAYED = 'last-played'
+KEY_LAST_POSITION = 'last-position'
+KEY_LICENSE = 'license'
+KEY_LYRICS = 'lyrics'
+KEY_MIME = 'mime'
+KEY_PLAY_COUNT = 'play-count'
+KEY_RATING = 'rating'
+KEY_SITE = 'site'
+KEY_SOURCE = 'source'
+KEY_STUDIO = 'studio'
+KEY_THUMBNAIL = 'thumbnail'
+KEY_TITLE = 'title'
+KEY_URL = 'url'
+KEY_WIDTH = 'width'
+
+REGISTERED_KEYS = [KEY_ALBUM, KEY_ARTIST, KEY_AUTHOR, KEY_BITRATE,
+ KEY_CERTIFICATE, KEY_CHILDCOUNT, KEY_DATE,
+ KEY_DESCRIPTION, KEY_DURATION, KEY_EXTERNAL_PLAYER,
+ KEY_EXTERNAL_URL, KEY_FRAMERATE, KEY_GENRE, KEY_HEIGHT,
+ KEY_ID, KEY_LAST_PLAYED, KEY_LAST_POSITION, KEY_LICENSE,
+ KEY_LYRICS, KEY_MIME, KEY_PLAY_COUNT, KEY_RATING,
+ KEY_SITE, KEY_SOURCE, KEY_STUDIO, KEY_THUMBNAIL,
+ KEY_TITLE, KEY_URL, KEY_WIDTH]
+
+SUPPORTED_OPS = []
+try:
+ from gi.repository import Grl
+ SUPPORTED_OPS = [Grl.SupportedOps.NONE, Grl.SupportedOps.METADATA,
+ Grl.SupportedOps.RESOLVE, Grl.SupportedOps.BROWSE,
+ Grl.SupportedOps.SEARCH, Grl.SupportedOps.QUERY,
+ Grl.SupportedOps.STORE, Grl.SupportedOps.STORE_PARENT,
+ Grl.SupportedOps.REMOVE, Grl.SupportedOps.SET_METADATA]
+except:
+ pass
diff --git a/media-libs/grilo/files/grilo-0.1.16-fix-automagic-test-ui.patch b/media-libs/grilo/files/grilo-0.1.16-fix-automagic-test-ui.patch
new file mode 100644
index 000000000000..64ae0c3b31c2
--- /dev/null
+++ b/media-libs/grilo/files/grilo-0.1.16-fix-automagic-test-ui.patch
@@ -0,0 +1,32 @@
+--- configure.ac
++++ configure.ac
+@@ -104,12 +104,25 @@
+ # UI Tool
+ # ----------------------------------------------------------
+
+-gtkver="gtk+-3.0"
+-PKG_CHECK_EXISTS([gtk+-3.0 >= 3.0], [gtkver="gtk+-3.0"], [gtkver="gtk+-2.0"])
+-
+-PKG_CHECK_MODULES([GTU], [ ${gtkver} ],
++PKG_CHECK_MODULES([GTU], [ gtk+-3.0 >= 3.0 ],
+ [ BUILD_GRILO_TEST_UI=yes ],
+ [ BUILD_GRILO_TEST_UI=no ])
++AC_ARG_ENABLE([test_ui],
++ AS_HELP_STRING([--enable-test-ui],
++ [Enable Grilo Test UI (default: auto)]),
++ [
++ case "$enableval" in
++ yes)
++ if test "x$BUILD_GRILO_TEST_UI" = "xno"; then
++ AC_MSG_ERROR([gtk+-3.0 >= 3.0 not found, install it
++ or use --disable-test-ui])
++ fi
++ ;;
++ no)
++ BUILD_GRILO_TEST_UI=no
++ ;;
++ esac
++ ])
+
+ AM_CONDITIONAL(BUILD_GRILO_TEST_UI, test "x$BUILD_GRILO_TEST_UI" = "xyes")
+
diff --git a/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch b/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch
new file mode 100644
index 000000000000..755faac9d2af
--- /dev/null
+++ b/media-libs/grilo/files/grilo-0.1.16-media-source-infinite-loop.patch
@@ -0,0 +1,48 @@
+From df228459d4332f3cb675d28d1d4185ae22929b81 Mon Sep 17 00:00:00 2001
+From: Lionel Landwerlin <lionel.g.landwerlin@linux.intel.com>
+Date: Wed, 29 Jun 2011 13:13:38 +0000
+Subject: media-source: manage end of search/browse with splitted sources
+
+When running in splitted modes (usually when dealing with websites),
+if you get less results than what the user would like to get, we
+currently end up in an infinite loop with the core of grilo keeping
+asking for new items from a source which can't deliver anymore.
+
+To manage this specific case, we just check whether the plugin has
+returned a remaining results number equals to 0 as well as a null
+item.
+
+Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@linux.intel.com>
+---
+diff --git a/src/grl-media-source.c b/src/grl-media-source.c
+index 459e29c..00494c3 100644
+--- a/src/grl-media-source.c
++++ b/src/grl-media-source.c
+@@ -643,8 +643,6 @@ browse_result_relay_cb (GrlMediaSource *source,
+
+ brc = (struct BrowseRelayCb *) user_data;
+
+- plugin_remaining = remaining;
+-
+ /* --- operation cancel management --- */
+
+ /* Check if operation is still valid , otherwise do not emit the result
+@@ -697,9 +695,13 @@ browse_result_relay_cb (GrlMediaSource *source,
+ as_info->count--;
+ as_info->chunk_consumed++;
+
+- /* FIXME: If we received less than we requested we should
+- not do an extra query */
+- remaining = as_info->count;
++ /* When auto split, if less results than what a chunk should give,
++ * that means we've reached the end of the results. */
++ if ((plugin_remaining == 0) &&
++ (as_info->chunk_consumed < as_info->chunk_requested))
++ remaining = 0;
++ else
++ remaining = as_info->count;
+ }
+
+ /* --- relay operation --- */
+--
+cgit v0.9
diff --git a/media-libs/grilo/grilo-0.1.16.ebuild b/media-libs/grilo/grilo-0.1.16.ebuild
new file mode 100644
index 000000000000..685275adafcf
--- /dev/null
+++ b/media-libs/grilo/grilo-0.1.16.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.1.16.ebuild,v 1.1 2011/08/14 10:52:25 nirbheek Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A framework for easy media discovery and browsing"
+HOMEPAGE="https://live.gnome.org/Grilo"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +introspection +network test test-ui vala"
+
+RDEPEND="
+ >=dev-libs/glib-2.22:2
+ dev-libs/libxml2:2
+ network? ( >=net-libs/libsoup-2.33.4:2.4 )
+ test-ui? ( >=x11-libs/gtk+-3.0:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.12[vapigen] )
+ test? (
+ dev-python/pygobject:2[introspection?]
+ media-plugins/grilo-plugins )"
+
+# Tests fail horribly, but return 0
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README TODO"
+ # --enable-debug only changes CFLAGS, useless for us
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ --disable-static
+ --disable-debug
+ VALAC=$(type -P valac-0.12)
+ VALA_GEN_INTROSPECT=$(type -P vala-gen-introspect-0.12)
+ VAPIGEN=$(type -P vapigen-0.12)
+ $(use_enable introspection)
+ $(use_enable network grl-net)
+ $(use_enable test tests)
+ $(use_enable test-ui)
+ $(use_enable vala)"
+}
+
+src_prepare() {
+ # Don't build examples
+ sed -e '/SUBDIRS/s/examples//' \
+ -i Makefile.am -i Makefile.in || die
+
+ # Various patches from upstream trunk
+ epatch "${FILESDIR}/${P}-media-source-infinite-loop.patch"
+
+ # Fix Test-UI automagic gtk2/gtk3 selection
+ epatch "${FILESDIR}/${PN}-0.1.16-fix-automagic-test-ui.patch"
+
+ # Build system doesn't install this file with the tarball
+ cp "${FILESDIR}/${PN}-0.1.16-constants.py" "${S}/tests/python/constants.py"
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ cd tests/
+ emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ # Install example code
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.c
+ fi
+}