summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-04-13 08:53:32 +0000
committerMart Raudsepp <leio@gentoo.org>2011-04-13 08:53:32 +0000
commita6497648afecf93f662a7e27883ba088495a7d87 (patch)
treefe72ca4f6146abb21268fe822c39e2bdb8216f07 /media-libs/gst-plugins-bad
parentFinish gst-plugins-0.10.21 changes (diff)
downloadgentoo-2-a6497648afecf93f662a7e27883ba088495a7d87.tar.gz
gentoo-2-a6497648afecf93f662a7e27883ba088495a7d87.tar.bz2
gentoo-2-a6497648afecf93f662a7e27883ba088495a7d87.zip
Version bump. Disable examples building as they aren't installed anyway, also avoiding problems similar to bug 348623. Remove useless debug USE flag - it didn't work correctly and existed only due to previous oversight - and it could only affect -g passing, which is handled via CFLAGS in make.conf
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gst-plugins-bad')
-rw-r--r--media-libs/gst-plugins-bad/ChangeLog28
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-0.10.21.ebuild56
-rw-r--r--media-libs/gst-plugins-bad/metadata.xml4
3 files changed, 87 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-bad/ChangeLog b/media-libs/gst-plugins-bad/ChangeLog
index b51f9791dd85..66b76663b20d 100644
--- a/media-libs/gst-plugins-bad/ChangeLog
+++ b/media-libs/gst-plugins-bad/ChangeLog
@@ -1,6 +1,32 @@
# ChangeLog for media-libs/gst-plugins-bad
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.75 2011/03/11 18:15:55 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/ChangeLog,v 1.76 2011/04/13 08:53:32 leio Exp $
+
+*gst-plugins-bad-0.10.21 (13 Apr 2011)
+
+ 13 Apr 2011; Mart Raudsepp <leio@gentoo.org> metadata.xml,
+ +gst-plugins-bad-0.10.21.ebuild:
+ Version bump. Disable examples building as they aren't installed anyway,
+ also avoiding problems similar to bug 348623. Remove useless debug USE
+ flag - it didn't work correctly and existed only due to previous oversight
+ - and it could only affect -g passing, which is handled via CFLAGS in
+ make.conf in Gentoo.
+ Many improvements, bug fixes, and so on as usual, refer to upstream NEWS;
+ New upstream plugins and elements since previous 0.10.19 version:
+ * coloreffects - Color Look-up Table filters
+ * gaudieffects - Gaudi video effects (burn, dilate, dodge, etc)
+ * geometrictransform - Various geometric image transform elements
+ * ivfparse - IVF parser (demuxes a IVF stream, which contains raw VP8)
+ * videomaxrate - Video maximum rate adjuster
+ * colorspace - ORC optimized colorspace converter
+ * dvbsuboverlay - DVB subtitles renderer/overlay
+ * interlace - Create an interlaced video stream
+ * jp2kdecimator - JPEG2000 decimator
+ * y4mdec - Demuxes/decodes YUV4MPEG streams
+ * audioparsers - New dcaparse (dts/dca parser) and mpegaudioparse elements
+ (mp3parse replacement)
+ * autoconvert - New autovideoconvert element
+ * debugutilsbad - New checksumsink and chopmydata debug elements
11 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gst-plugins-bad-0.10.19.ebuild:
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.21.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.21.ebuild
new file mode 100644
index 000000000000..e40b8ee6279c
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-bad/gst-plugins-bad-0.10.21.ebuild,v 1.1 2011/04/13 08:53:32 leio Exp $
+
+EAPI=1
+GCONF_DEBUG="no"
+
+inherit gst-plugins-bad gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="+orc"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.32
+ >=media-libs/gstreamer-0.10.32
+ >=dev-libs/glib-2.22
+ orc? ( >=dev-lang/orc-0.4.7 )
+ !<media-plugins/gst-plugins-farsight-0.12.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# Avoid --enable-bad passing by the eclass blindly
+GST_PLUGINS_BUILD=""
+
+src_compile() {
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # (Bug #22249)
+
+ gst-plugins-bad_src_configure \
+ $(use_enable orc) \
+ --disable-examples \
+ --disable-debug
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}
diff --git a/media-libs/gst-plugins-bad/metadata.xml b/media-libs/gst-plugins-bad/metadata.xml
index d1096fb54bd8..eaed39bb1d6e 100644
--- a/media-libs/gst-plugins-bad/metadata.xml
+++ b/media-libs/gst-plugins-bad/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gstreamer</herd>
+ <use>
+ <flag name="orc">Use <pkg>dev-lang/orc</pkg> for runtime
+ optimisations</flag>
+ </use>
</pkgmetadata>