summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2005-12-02 22:23:08 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2005-12-02 22:23:08 +0000
commite267ee1e478d955febb4a949a3787a3d9c7ca11c (patch)
tree71685e8128a67be275f94dd8c4a50693f57e11c0 /media-libs/gst-plugins-good
parentmarked ~alpha wrt bug #113367 (diff)
downloadgentoo-2-e267ee1e478d955febb4a949a3787a3d9c7ca11c.tar.gz
gentoo-2-e267ee1e478d955febb4a949a3787a3d9c7ca11c.tar.bz2
gentoo-2-e267ee1e478d955febb4a949a3787a3d9c7ca11c.zip
0.10 Prerelease
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog10
-rw-r--r--media-libs/gst-plugins-good/Manifest2
-rw-r--r--media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.9.71
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.9.7.ebuild74
-rw-r--r--media-libs/gst-plugins-good/metadata.xml5
5 files changed, 92 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
new file mode 100644
index 000000000000..e176c3979a05
--- /dev/null
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/gst-plugins-good
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.1 2005/12/02 22:23:08 zaheerm Exp $
+
+*gst-plugins-good-0.9.7 (02 Dec 2005)
+
+ 02 Dec 2005; <zaheer@gentoo.org> +metadata.xml,
+ +gst-plugins-good-0.9.7.ebuild:
+ 0.10 Prerelease
+
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
new file mode 100644
index 000000000000..b293a5fd393f
--- /dev/null
+++ b/media-libs/gst-plugins-good/Manifest
@@ -0,0 +1,2 @@
+MD5 99ed028905cb1f0949209bdcaaef4e81 gst-plugins-good-0.9.7.ebuild 1630
+MD5 0325912c1d2f4bb76987df68a557149e files/digest-gst-plugins-good-0.9.7 75
diff --git a/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.9.7 b/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.9.7
new file mode 100644
index 000000000000..8bcc41f7963c
--- /dev/null
+++ b/media-libs/gst-plugins-good/files/digest-gst-plugins-good-0.9.7
@@ -0,0 +1 @@
+MD5 f55f27cecc6a0fe370312ccf0acd6d3e gst-plugins-good-0.9.7.tar.bz2 890561
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.9.7.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.9.7.ebuild
new file mode 100644
index 000000000000..c2a41327765a
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.9.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.9.7.ebuild,v 1.1 2005/12/02 22:23:08 zaheerm Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.9.7
+ >=dev-libs/liboil-0.3.3"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins-good_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+
+}
diff --git a/media-libs/gst-plugins-good/metadata.xml b/media-libs/gst-plugins-good/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/media-libs/gst-plugins-good/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>