summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-01-22 22:36:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-01-22 22:36:57 +0000
commite92d2a150d627d6a0f3cdf3a275d7a96e5d74f25 (patch)
treed6f84c988e452760fcf0f6ca645ca53e23d009b1 /media-libs/gst-plugins-ugly
parentversion bump (bug #396189) (diff)
downloadgentoo-2-e92d2a150d627d6a0f3cdf3a275d7a96e5d74f25.tar.gz
gentoo-2-e92d2a150d627d6a0f3cdf3a275d7a96e5d74f25.tar.bz2
gentoo-2-e92d2a150d627d6a0f3cdf3a275d7a96e5d74f25.zip
Version bump.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/gst-plugins-ugly')
-rw-r--r--media-libs/gst-plugins-ugly/ChangeLog10
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.5.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/media-libs/gst-plugins-ugly/ChangeLog b/media-libs/gst-plugins-ugly/ChangeLog
index 933dccc39424..8f5a02f5105a 100644
--- a/media-libs/gst-plugins-ugly/ChangeLog
+++ b/media-libs/gst-plugins-ugly/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-ugly
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.102 2012/12/20 03:32:58 tetromino Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/ChangeLog,v 1.103 2013/01/22 22:36:57 eva Exp $
+
+*gst-plugins-ugly-1.0.5 (22 Jan 2013)
+
+ 22 Jan 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gst-plugins-ugly-1.0.5.ebuild:
+ Version bump.
20 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> metadata.xml:
Switch to global orc USE flag.
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.5.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.5.ebuild
new file mode 100644
index 000000000000..99e8e1f6c435
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.0.5.ebuild,v 1.1 2013/01/22 22:36:57 eva Exp $
+
+EAPI="5"
+
+# order is important, gst-plugins10 after gst-plugins
+inherit eutils flag-o-matic gst-plugins-ugly gst-plugins10
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-1:${SLOT}
+ >=media-libs/gst-plugins-base-1:${SLOT}
+ orc? ( >=dev-lang/orc-0.4.16 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins10_src_configure
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
+}