summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-05 16:21:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-05 16:21:43 +0000
commitfe4a4a7b9e82aa3508e3c53a92af1169c6b75c6a (patch)
tree7f906af71a34e203bce213d79484960e7bf0e736 /media-libs/gst-plugins
parentBug 114071, dep for asterisk/festival scripts (diff)
downloadgentoo-2-fe4a4a7b9e82aa3508e3c53a92af1169c6b75c6a.tar.gz
gentoo-2-fe4a4a7b9e82aa3508e3c53a92af1169c6b75c6a.tar.bz2
gentoo-2-fe4a4a7b9e82aa3508e3c53a92af1169c6b75c6a.zip
resurrect gst-plugins-0.8.8-r2.ebuild gst-plugins-0.8.9-r2.ebuild to fix broken deps
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-libs/gst-plugins')
-rw-r--r--media-libs/gst-plugins/ChangeLog7
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.8.8-r21
-rw-r--r--media-libs/gst-plugins/files/digest-gst-plugins-0.8.9-r21
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.8.8-r2.ebuild91
-rw-r--r--media-libs/gst-plugins/gst-plugins-0.8.9-r2.ebuild95
5 files changed, 194 insertions, 1 deletions
diff --git a/media-libs/gst-plugins/ChangeLog b/media-libs/gst-plugins/ChangeLog
index fe87adf3da47..dc886b9aef3f 100644
--- a/media-libs/gst-plugins/ChangeLog
+++ b/media-libs/gst-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gst-plugins
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.129 2005/12/04 14:00:09 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/ChangeLog,v 1.130 2005/12/05 16:21:43 mr_bones_ Exp $
+
+ 05 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +gst-plugins-0.8.8-r2.ebuild, +gst-plugins-0.8.9-r2.ebuild:
+ resurrect gst-plugins-0.8.8-r2.ebuild gst-plugins-0.8.9-r2.ebuild to fix
+ broken deps
04 Dec 2005; Zaheer Abbas Merali <zaheerm@gentoo.org>
-gst-plugins-0.8.2.ebuild, -gst-plugins-0.8.8.ebuild,
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.8.8-r2 b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.8-r2
new file mode 100644
index 000000000000..e862979669af
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.8-r2
@@ -0,0 +1 @@
+MD5 4f6e7e730fa674ecd6ec713f937b8acb gst-plugins-0.8.8.tar.bz2 2214274
diff --git a/media-libs/gst-plugins/files/digest-gst-plugins-0.8.9-r2 b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.9-r2
new file mode 100644
index 000000000000..346795226dc3
--- /dev/null
+++ b/media-libs/gst-plugins/files/digest-gst-plugins-0.8.9-r2
@@ -0,0 +1 @@
+MD5 663461ef7b16e9bd7f2605e4ed0db5ba gst-plugins-0.8.9.tar.bz2 2356958
diff --git a/media-libs/gst-plugins/gst-plugins-0.8.8-r2.ebuild b/media-libs/gst-plugins/gst-plugins-0.8.8-r2.ebuild
new file mode 100644
index 000000000000..c108dce5301c
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.8.8-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.8.8-r2.ebuild,v 1.12 2005/12/05 16:21:43 mr_bones_ Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="esd alsa oss"
+
+RDEPEND=">=media-libs/gstreamer-0.8.9
+ >=gnome-base/gconf-2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND="oss? ( >=media-plugins/gst-plugins-oss-${PV} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${PV} )
+ esd? ( >=media-plugins/gst-plugins-esd-${PV} )"
+
+# we need x for the x overlay to get linked
+GST_PLUGINS_BUILD="x xshm"
+
+# overrides the eclass
+src_unpack() {
+
+ unpack ${A}
+
+ # qtdemux patch to fix qdm2
+ cd ${S}/gst/qtdemux
+ epatch ${FILESDIR}/${P}-qtdemux.diff.gz
+
+ # subtitle font selection for playbin (totem 1.1.1 uses)
+ cd ${S}/gst/playback
+ epatch ${FILESDIR}/${P}-gstplaybin_subfont.patch
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+ gst-plugins_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ gst-plugins_pkg_postrm
+
+}
diff --git a/media-libs/gst-plugins/gst-plugins-0.8.9-r2.ebuild b/media-libs/gst-plugins/gst-plugins-0.8.9-r2.ebuild
new file mode 100644
index 000000000000..cb464bafabea
--- /dev/null
+++ b/media-libs/gst-plugins/gst-plugins-0.8.9-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins/gst-plugins-0.8.9-r2.ebuild,v 1.6 2005/12/05 16:21:43 mr_bones_ Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="esd alsa oss"
+
+RDEPEND=">=media-libs/gstreamer-0.8.10
+ >=gnome-base/gconf-2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ >=dev-util/pkgconfig-0.9"
+
+PDEPEND="oss? ( >=media-plugins/gst-plugins-oss-${PV} )
+ alsa? ( >=media-plugins/gst-plugins-alsa-${PV} )
+ esd? ( >=media-plugins/gst-plugins-esd-${PV} )"
+
+# we need x for the x overlay to get linked
+GST_PLUGINS_BUILD="x xshm"
+
+# overrides the eclass
+src_unpack() {
+ unpack ${A}
+
+ # fix ximagesrc to work in gst-inspect
+ cd ${S}/sys/ximage
+ epatch ${FILESDIR}/${P}-ximagefix.patch
+
+ # fix qtdemux so raw pcm files sound proper
+ cd ${S}/gst/qtdemux
+ epatch ${FILESDIR}/${P}-qtdemux-fixrawpcm.patch
+
+ # add iso mpeg4 support to avi
+ cd ${S}/gst-libs/gst/riff
+ epatch ${FILESDIR}/${P}-riffmedia-isompeg4.patch
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+ if use alpha || use amd64 || use ia64 || use hppa; then
+ append-flags -fPIC
+ fi
+
+ gst-plugins_src_configure
+
+ emake || die
+
+}
+
+# override eclass
+src_install() {
+
+ gnome2_src_install
+
+}
+
+DOCS="AUTHORS INSTALL README RELEASE TODO"
+
+pkg_postinst () {
+
+ gnome2_pkg_postinst
+ gst-plugins_pkg_postinst
+
+ echo ""
+ einfo "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ einfo "applications now should provide the basic plugins needed."
+ echo ""
+ einfo "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ einfo "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ einfo "In most cases it shouldn't be needed though to emerge extra plugins."
+
+}
+
+pkg_postrm() {
+
+ gnome2_pkg_postrm
+ gst-plugins_pkg_postrm
+
+}