summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-24 13:39:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-24 13:39:17 +0000
commit02cc54c9dfbcaf5786d6b5b4b517e99e3a0f396a (patch)
treec099efb2539d39fb31774a7d5a9c962ba6105e11 /media-libs/gstreamer
parentVersion bump (diff)
downloadgentoo-2-02cc54c9dfbcaf5786d6b5b4b517e99e3a0f396a.tar.gz
gentoo-2-02cc54c9dfbcaf5786d6b5b4b517e99e3a0f396a.tar.bz2
gentoo-2-02cc54c9dfbcaf5786d6b5b4b517e99e3a0f396a.zip
Drop .la files as unnecessary libtool files.
(Portage version: 2.1.6.2/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/ChangeLog7
-rw-r--r--media-libs/gstreamer/gstreamer-0.10.21-r2.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
index aa3e9345199b..c1c8a9980e8b 100644
--- a/media-libs/gstreamer/ChangeLog
+++ b/media-libs/gstreamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gstreamer
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.214 2008/12/24 11:53:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.215 2008/12/24 13:39:17 ssuominen Exp $
+
+*gstreamer-0.10.21-r2 (24 Dec 2008)
+
+ 24 Dec 2008; <ssuominen@gentoo.org> +gstreamer-0.10.21-r2.ebuild:
+ Drop .la files as unnecessary libtool files.
*gstreamer-0.10.21-r1 (24 Dec 2008)
diff --git a/media-libs/gstreamer/gstreamer-0.10.21-r2.ebuild b/media-libs/gstreamer/gstreamer-0.10.21-r2.ebuild
new file mode 100644
index 000000000000..35a528a26f68
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-0.10.21-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-0.10.21-r2.ebuild,v 1.1 2008/12/24 13:39:17 ssuominen Exp $
+
+EAPI=2
+
+inherit autotools eutils multilib versionator
+#inherit libtool versionator
+
+# Create a major/minor combo for our SLOT and executables suffix
+PV_MAJ_MIN=$(get_version_component_range '1-2')
+
+DESCRIPTION="Streaming media framework"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT=${PV_MAJ_MIN}
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls test"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ dev-libs/libxml2
+ >=dev-libs/check-0.9.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # Needed for sane .so versioning on Gentoo/FreeBSD
+ #elibtoolize
+ epatch "${FILESDIR}"/${P}-gtkdoc.patch \
+ "${FILESDIR}"/${P}-bison241.patch
+ AT_M4DIR="common/m4" eautoreconf
+}
+
+src_configure() {
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ --disable-valgrind \
+ --disable-examples \
+ $(use_enable test tests) \
+ --with-package-name="GStreamer ebuild for Gentoo" \
+ --with-package-origin="http://packages.gentoo.org/package/media-libs/gstreamer"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE
+
+ # Remove unversioned binaries to allow SLOT installations in future
+ cd "${D}"/usr/bin
+ local gst_bins
+ for gst_bins in $(ls *-${PV_MAJ_MIN}); do
+ rm -f ${gst_bins/-${PV_MAJ_MIN}/}
+ done
+
+ # Drop unnecessary libtool files
+ find "${D}" -name '*.la' -delete || die "find and delete failed."
+}