summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-29 07:02:04 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-29 07:02:04 +0000
commit2f24408ba60945a4bb8b8488e1f39cd461e3a25d (patch)
tree413b36f4addbcf52bbf4d57ce61cff341bd42f1a /media-libs/gstreamer
parentVersion bump. Ebuild by Peter Wilmott in the ruby overlay. (diff)
downloadgentoo-2-2f24408ba60945a4bb8b8488e1f39cd461e3a25d.tar.gz
gentoo-2-2f24408ba60945a4bb8b8488e1f39cd461e3a25d.tar.bz2
gentoo-2-2f24408ba60945a4bb8b8488e1f39cd461e3a25d.zip
Fix compilation with >=sys-devel/bison-3.0 (bug #478676)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/ChangeLog6
-rw-r--r--media-libs/gstreamer/files/gstreamer-make-grammar.y-work-with-bison-3.patch33
-rw-r--r--media-libs/gstreamer/gstreamer-0.10.36.ebuild7
3 files changed, 43 insertions, 3 deletions
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
index fbe36c03f3e2..0dd87af7d847 100644
--- a/media-libs/gstreamer/ChangeLog
+++ b/media-libs/gstreamer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/gstreamer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.365 2014/04/21 10:29:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/ChangeLog,v 1.366 2014/04/29 07:02:03 polynomial-c Exp $
+
+ 29 Apr 2014; Lars Wendler <polynomial-c@gentoo.org> gstreamer-0.10.36.ebuild,
+ +files/gstreamer-make-grammar.y-work-with-bison-3.patch:
+ Fix compilation with >=sys-devel/bison-3.0 (bug #478676).
21 Apr 2014; Agostino Sarubbo <ago@gentoo.org> gstreamer-1.2.3.ebuild:
Stable for arm, wrt bug #507568
diff --git a/media-libs/gstreamer/files/gstreamer-make-grammar.y-work-with-bison-3.patch b/media-libs/gstreamer/files/gstreamer-make-grammar.y-work-with-bison-3.patch
new file mode 100644
index 000000000000..56bd5979c504
--- /dev/null
+++ b/media-libs/gstreamer/files/gstreamer-make-grammar.y-work-with-bison-3.patch
@@ -0,0 +1,33 @@
+From 90622bb35544655cf641e3ab65cf35a6d01869bc Mon Sep 17 00:00:00 2001
+From: Kerrick Staley <kerrick@kerrickstaley.com>
+Date: Tue, 20 Aug 2013 23:59:29 -0700
+Subject: [PATCH] Make grammar.y work with Bison 3
+
+YYLEX_PARAM is no longer supported in Bison 3.
+---
+ gst/parse/grammar.y | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
+index 8a9019c..f533389 100644
+--- a/gst/parse/grammar.y
++++ b/gst/parse/grammar.y
+@@ -26,7 +26,6 @@
+ */
+
+ #define YYERROR_VERBOSE 1
+-#define YYLEX_PARAM scanner
+
+ #define YYENABLE_NLS 0
+
+@@ -659,6 +658,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
+ %right '.'
+ %left '!' '='
+
++%lex-param { void *scanner }
+ %parse-param { void *scanner }
+ %parse-param { graph_t *graph }
+ %pure-parser
+--
+1.8.3.4
+
diff --git a/media-libs/gstreamer/gstreamer-0.10.36.ebuild b/media-libs/gstreamer/gstreamer-0.10.36.ebuild
index f47b6203447b..dd26af5ac780 100644
--- a/media-libs/gstreamer/gstreamer-0.10.36.ebuild
+++ b/media-libs/gstreamer/gstreamer-0.10.36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-0.10.36.ebuild,v 1.15 2013/02/24 17:54:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gstreamer/gstreamer-0.10.36.ebuild,v 1.16 2014/04/29 07:02:03 polynomial-c Exp $
EAPI=4
@@ -34,6 +34,9 @@ src_prepare() {
# Disable silly test that's not guaranteed to pass on an arbitrary machine
epatch "${FILESDIR}/${PN}-0.10.36-disable-test_fail_abstract_new.patch"
+ # Fix compilation with >=sys-devel/bison-3.0 (#478676)
+ epatch "${FILESDIR}/${PN}-make-grammar.y-work-with-bison-3.patch"
+
# Disable windows-portability tests that are relevant only on x86 and amd64
# and can fail on other arches (bug #455038)
if [[ ${ABI} != x86 && ${ABI} != amd64 ]]; then