summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-04-28 18:46:52 +0000
committerJon Hood <squinky86@gentoo.org>2004-04-28 18:46:52 +0000
commit8215740957668078e22e143c6e1b05e39e7c922a (patch)
tree3a7f8e443b5690420ceb8ef5faecdc86683174f7 /media-libs/libextractor/libextractor-0.2.6.ebuild
parentMoving to media-libs/libextractor (diff)
downloadgentoo-2-8215740957668078e22e143c6e1b05e39e7c922a.tar.gz
gentoo-2-8215740957668078e22e143c6e1b05e39e7c922a.tar.bz2
gentoo-2-8215740957668078e22e143c6e1b05e39e7c922a.zip
move to media-libs
Diffstat (limited to 'media-libs/libextractor/libextractor-0.2.6.ebuild')
-rw-r--r--media-libs/libextractor/libextractor-0.2.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libextractor/libextractor-0.2.6.ebuild b/media-libs/libextractor/libextractor-0.2.6.ebuild
new file mode 100644
index 000000000000..f0eed04790b9
--- /dev/null
+++ b/media-libs/libextractor/libextractor-0.2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libextractor/libextractor-0.2.6.ebuild,v 1.1 2004/04/28 18:46:52 squinky86 Exp $
+
+inherit libtool
+
+IUSE="oggvorbis static"
+DESCRIPTION="A simple library for keyword extraction"
+HOMEPAGE="http://www.ovmj.org/~samanta/libextractor"
+SRC_URI="http://www.ovmj.org/~samanta/libextractor/download/${P}.tar.bz2"
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~amd64"
+DEPEND=">=sys-devel/libtool-1.4.1
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
+
+src_compile() {
+ elibtoolize
+
+ myconf="--with-gnu-ld"
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+ econf ${myconf} || die "econf failed"
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}