summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-10-21 13:31:16 +0000
committerJory Pratt <anarchy@gentoo.org>2010-10-21 13:31:16 +0000
commitf32613e692951a9ee698e9c8a4a45a85dbae8b11 (patch)
tree75c742b76acebc876d0bec4fdc2c008fe5988741 /media-libs/libjpeg-turbo
parentAdd pam herd to the maintainers (for USE=pam); unbreak /etc/pam.d/login that ... (diff)
downloadgentoo-2-f32613e692951a9ee698e9c8a4a45a85dbae8b11.tar.gz
gentoo-2-f32613e692951a9ee698e9c8a4a45a85dbae8b11.tar.bz2
gentoo-2-f32613e692951a9ee698e9c8a4a45a85dbae8b11.zip
current svn snapshot, jpeg-8 support enabled by default
(Portage version: 2.1.9.20/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libjpeg-turbo')
-rw-r--r--media-libs/libjpeg-turbo/ChangeLog8
-rw-r--r--media-libs/libjpeg-turbo/libjpeg-turbo-1.0.90.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/libjpeg-turbo/ChangeLog b/media-libs/libjpeg-turbo/ChangeLog
index b463ee2a5e58..2d6e0044d847 100644
--- a/media-libs/libjpeg-turbo/ChangeLog
+++ b/media-libs/libjpeg-turbo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libjpeg-turbo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libjpeg-turbo/ChangeLog,v 1.2 2010/09/20 17:57:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjpeg-turbo/ChangeLog,v 1.3 2010/10/21 13:31:16 anarchy Exp $
+
+*libjpeg-turbo-1.0.90 (21 Oct 2010)
+
+ 21 Oct 2010; Jory A. Pratt <anarchy@gentoo.org>
+ +libjpeg-turbo-1.0.90.ebuild:
+ current svn snapshot, jpeg-8 support enabled by default
*libjpeg-turbo-1.0.1 (20 Sep 2010)
diff --git a/media-libs/libjpeg-turbo/libjpeg-turbo-1.0.90.ebuild b/media-libs/libjpeg-turbo/libjpeg-turbo-1.0.90.ebuild
new file mode 100644
index 000000000000..70eb7232dbd6
--- /dev/null
+++ b/media-libs/libjpeg-turbo/libjpeg-turbo-1.0.90.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libjpeg-turbo/libjpeg-turbo-1.0.90.ebuild,v 1.1 2010/10/21 13:31:15 anarchy Exp $
+
+EAPI=2
+inherit libtool
+
+DESCRIPTION="MMX, SSE, and SSE2 SIMD accellerated jpeg library"
+HOMEPAGE="http://sourceforge.net/projects/libjpeg-turbo/"
+SRC_URI="http://dev.gentoo.org/~anarchy/dist/${P}.tar.bz2"
+
+LICENSE="as-is LGPL-2.1 wxWinLL-3.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="!media-libs/jpeg:0
+ !media-libs/jpeg:62"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --with-jpeg8 \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUILDING.txt ChangeLog.txt example.c README-turbo.txt
+ find "${D}" -name '*.la' -delete
+}