summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 08:47:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-16 08:47:00 +0000
commit14baa32951a3166c1f9adb5c2f2258be9e497577 (patch)
tree10dd239e521561aeb20571010057254df4cba410 /media-libs/libmpeg2
parentdon't assign to A (bug #44712); use mirror://; no need to set RDEPEND="$DEPEN... (diff)
downloadgentoo-2-14baa32951a3166c1f9adb5c2f2258be9e497577.tar.gz
gentoo-2-14baa32951a3166c1f9adb5c2f2258be9e497577.tar.bz2
gentoo-2-14baa32951a3166c1f9adb5c2f2258be9e497577.zip
append-flags into src_unpack; use/depend on sed-4; use use_enable/use_with
Diffstat (limited to 'media-libs/libmpeg2')
-rw-r--r--media-libs/libmpeg2/ChangeLog7
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.4.0.ebuild43
2 files changed, 23 insertions, 27 deletions
diff --git a/media-libs/libmpeg2/ChangeLog b/media-libs/libmpeg2/ChangeLog
index 67ce0d1908e7..a3355d5a436f 100644
--- a/media-libs/libmpeg2/ChangeLog
+++ b/media-libs/libmpeg2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libmpeg2
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.14 2004/01/03 20:55:22 lu_zero Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.15 2004/03/16 08:47:00 mr_bones_ Exp $
+
+ 16 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> libmpeg2-0.4.0.ebuild:
+ append-flags into src_unpack; use/depend on sed-4; use use_enable/use_with
*libmpeg2-0.4.0 (03 Jan 2004)
diff --git a/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild b/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild
index 22921ae52d9f..7cdf7b222d21 100644
--- a/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild
+++ b/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild,v 1.1 2004/01/03 20:55:22 lu_zero Exp $
-
-IUSE="sdl X"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.4.0.ebuild,v 1.2 2004/03/16 08:47:00 mr_bones_ Exp $
inherit libtool flag-o-matic
@@ -15,40 +13,35 @@ HOMEPAGE="http://libmpeg2.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
+IUSE="sdl X"
-DEPEND="sdl? ( media-libs/libsdl )
+RDEPEND="sdl? ( media-libs/libsdl )
X? ( virtual/x11 )"
-
-[ $ARCH = alpha ] && append-flags -fPIC
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_unpack() {
+ [ $ARCH = alpha ] && append-flags -fPIC
unpack ${A}
# get rid of the -mcpu
- cd ${S} ; cp configure configure.orig
- sed -e 's:OPT_CFLAGS=\"$CFLAGS -mcpu=.*\":OPT_CFLAGS=\"$CFLAGS\":g' \
- configure.orig > configure
+ cd ${S}
+ sed -i \
+ -e 's:OPT_CFLAGS=\"$CFLAGS -mcpu=.*\":OPT_CFLAGS=\"$CFLAGS\":g' \
+ configure || die "sed configure failed"
}
src_compile() {
elibtoolize
-
- local myconf=""
-
- use sdl \
- && myconf="${myconf} --enable-sdl" \
- || myconf="${myconf} --disable-sdl"
-
- use X && myconf="${myconf} --with-x" \
- || myconf="${myconf} --without-x"
-
- econf --enable-shared \
- ${myconf} || die "./configure failed"
- emake || make || die
+ econf \
+ --enable-shared \
+ `use_enable sdl` \
+ `use_with X x` \
+ || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
-
- dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
}