summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-11-14 21:54:42 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-11-14 21:54:42 +0000
commitc1792577ff77eaa4c226e849e005d483b564cc76 (patch)
treeefc57feba83b7c47841ed5b1a8cc22bc5e71c8e5 /media-libs/libmpeg2
parentStable on x86, bug #155079. (diff)
downloadgentoo-2-c1792577ff77eaa4c226e849e005d483b564cc76.tar.gz
gentoo-2-c1792577ff77eaa4c226e849e005d483b564cc76.tar.bz2
gentoo-2-c1792577ff77eaa4c226e849e005d483b564cc76.zip
Version bumped.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'media-libs/libmpeg2')
-rw-r--r--media-libs/libmpeg2/ChangeLog8
-rw-r--r--media-libs/libmpeg2/files/digest-libmpeg2-0.4.13
-rw-r--r--media-libs/libmpeg2/files/libmpeg2-0.4.1-use-readelf-for-test.patch26
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.4.1.ebuild68
4 files changed, 104 insertions, 1 deletions
diff --git a/media-libs/libmpeg2/ChangeLog b/media-libs/libmpeg2/ChangeLog
index f89c512d56ce..f36b0c980b89 100644
--- a/media-libs/libmpeg2/ChangeLog
+++ b/media-libs/libmpeg2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libmpeg2
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.50 2006/11/06 07:22:15 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.51 2006/11/14 21:54:42 zzam Exp $
+
+*libmpeg2-0.4.1 (14 Nov 2006)
+
+ 14 Nov 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/libmpeg2-0.4.1-use-readelf-for-test.patch, +libmpeg2-0.4.1.ebuild:
+ Version bumped.
06 Nov 2006; Javier Villavicencio <the_paya@gentoo.org>
libmpeg2-0.4.0b.ebuild:
diff --git a/media-libs/libmpeg2/files/digest-libmpeg2-0.4.1 b/media-libs/libmpeg2/files/digest-libmpeg2-0.4.1
new file mode 100644
index 000000000000..f0b7d3372b0b
--- /dev/null
+++ b/media-libs/libmpeg2/files/digest-libmpeg2-0.4.1
@@ -0,0 +1,3 @@
+MD5 7631b0a4bcfdd0d78c0bb0083080b0dc mpeg2dec-0.4.1.tar.gz 494539
+RMD160 5377ae45abdd37fabcea6d3d0a9d74e493b84483 mpeg2dec-0.4.1.tar.gz 494539
+SHA256 c74a76068f8ec36d4bb59a03bf1157be44118ca02252180e8b358b0b5e3edeee mpeg2dec-0.4.1.tar.gz 494539
diff --git a/media-libs/libmpeg2/files/libmpeg2-0.4.1-use-readelf-for-test.patch b/media-libs/libmpeg2/files/libmpeg2-0.4.1-use-readelf-for-test.patch
new file mode 100644
index 000000000000..7d091cfbb04e
--- /dev/null
+++ b/media-libs/libmpeg2/files/libmpeg2-0.4.1-use-readelf-for-test.patch
@@ -0,0 +1,26 @@
+--- test/globals.orig 2006-04-29 19:19:59.000000000 +0200
++++ test/globals 2006-04-29 19:24:35.000000000 +0200
+@@ -14,8 +14,9 @@
+
+ error=0
+
+-bad_globals=`nm -g --defined-only $builddir/../libmpeg2/*.o |\
+- awk '{if ($3) print $3}' | grep -v '^_\?mpeg2_'`
++bad_globals=`readelf -s $builddir/../libmpeg2/*.o |\
++ awk '$5=="GLOBAL" && $6!="HIDDEN" && $7!="UND" {print $8}' |\
++ grep -v '^_\?mpeg2_'`
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS:
+@@ -23,8 +24,9 @@
+ error=1
+ fi
+
+-bad_globals=`nm -g --defined-only $builddir/../libmpeg2/convert/*.o |\
+- awk '{if ($3) print $3}' | grep -v '^_\?mpeg2convert_'`
++bad_globals=`readelf -s $builddir/../libmpeg2/convert/*.o |\
++ awk '$5=="GLOBAL" && $6!="HIDDEN" && $7!="UND" {print $8}' |\
++ grep -v '^_\?mpeg2convert_'`
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS:
diff --git a/media-libs/libmpeg2/libmpeg2-0.4.1.ebuild b/media-libs/libmpeg2/libmpeg2-0.4.1.ebuild
new file mode 100644
index 000000000000..cb45c5fc8fbb
--- /dev/null
+++ b/media-libs/libmpeg2/libmpeg2-0.4.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.4.1.ebuild,v 1.1 2006/11/14 21:54:42 zzam Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+inherit eutils flag-o-matic autotools libtool
+
+MY_P="mpeg2dec-${PV}"
+DESCRIPTION="library for decoding mpeg-2 and mpeg-1 video"
+HOMEPAGE="http://libmpeg2.sourceforge.net/"
+SRC_URI="http://libmpeg2.sourceforge.net/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sdl X"
+
+DEPEND="sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libXv
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-proto/xextproto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use alpha && append-flags -fPIC
+
+ # get rid of the -mcpu
+ sed -i \
+ -e '/-mcpu/d' \
+ configure.in \
+ || die "sed configure failed"
+
+ # Fix problem that the test for external symbols
+ # uses nm which also displays hidden symbols. Bug #130831
+ epatch "${FILESDIR}/${P}-use-readelf-for-test.patch"
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ # x86 asm + 64bit binary == no worky (fixes bug 69227)
+ use amd64 && myconf="--disable-accel-detect"
+
+ econf \
+ --enable-shared \
+ --disable-dependency-tracking \
+ $(use_enable sdl) \
+ $(use_with X x) \
+ ${myconf} \
+ || die
+ # builds non-pic library by default? (bug #44934)
+ emake LIBMPEG2_CFLAGS= || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}