summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-28 13:22:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-28 13:22:26 +0000
commit4a5caaefcf70a8b15a4454cf2d09489d61c71c90 (patch)
treee02f1f4d1c97aa13575eba8b29917303e5e5121b /media-libs/libmpeg3
parentfixed bug #23291 (diff)
downloadgentoo-2-4a5caaefcf70a8b15a4454cf2d09489d61c71c90.tar.gz
gentoo-2-4a5caaefcf70a8b15a4454cf2d09489d61c71c90.tar.bz2
gentoo-2-4a5caaefcf70a8b15a4454cf2d09489d61c71c90.zip
gcc-2.x fix #25349 + ppc largefile fix
Diffstat (limited to 'media-libs/libmpeg3')
-rw-r--r--media-libs/libmpeg3/ChangeLog6
-rw-r--r--media-libs/libmpeg3/files/1.5.1-ppc-largefile.patch11
-rw-r--r--media-libs/libmpeg3/files/1.5.1-proper-c.patch13
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.5.1.ebuild4
4 files changed, 32 insertions, 2 deletions
diff --git a/media-libs/libmpeg3/ChangeLog b/media-libs/libmpeg3/ChangeLog
index 69d949df6dc9..3b13b9459355 100644
--- a/media-libs/libmpeg3/ChangeLog
+++ b/media-libs/libmpeg3/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for media-libs/libmpeg3
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.12 2003/07/26 22:34:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.13 2003/07/28 13:22:26 vapier Exp $
*libmpeg3-1.5.1 (26 Jul 2003)
+ 28 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch to fix gcc-2.x issues #25349 and another
+ to fix ppc largefile support.
+
26 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
Version bump + update patches + make sure quicktime4linux compiles.
diff --git a/media-libs/libmpeg3/files/1.5.1-ppc-largefile.patch b/media-libs/libmpeg3/files/1.5.1-ppc-largefile.patch
new file mode 100644
index 000000000000..229349115712
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-ppc-largefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2002-06-21 08:35:24.000000000 -0400
++++ Makefile 2003-07-28 09:15:44.000000000 -0400
+@@ -33,7 +33,7 @@
+
+
+ ifeq ($(USE_CSS), 1)
+- CFLAGS += -DHAVE_CSS
++ CFLAGS += -DHAVE_CSS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ endif
+
+ ifeq ($(USE_MMX), 1)
diff --git a/media-libs/libmpeg3/files/1.5.1-proper-c.patch b/media-libs/libmpeg3/files/1.5.1-proper-c.patch
new file mode 100644
index 000000000000..135dfb633562
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.1-proper-c.patch
@@ -0,0 +1,13 @@
+--- mpeg3toc.c.orig 2003-07-28 09:04:05.000000000 -0400
++++ mpeg3toc.c 2003-07-28 09:06:26.000000000 -0400
+@@ -196,9 +196,9 @@
+ if(!mpeg3_end_of_audio(input, j))
+ {
+ // Don't want to maintain separate vectors for offset and title.
+- title_number = mpeg3demux_tell_title(input->atrack[j]->demuxer);
+ int64_t position = mpeg3demux_tell(input->atrack[j]->demuxer);
+ int64_t result;
++ title_number = mpeg3demux_tell_title(input->atrack[j]->demuxer);
+ if(position < MPEG3_IO_SIZE) position = MPEG3_IO_SIZE;
+ result = (title_number << 56) | (position - MPEG3_IO_SIZE);
+
diff --git a/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
index c7ac83baf2be..e941d3983fa8 100644
--- a/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
+++ b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild,v 1.1 2003/07/26 22:34:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild,v 1.2 2003/07/28 13:22:26 vapier Exp $
inherit flag-o-matic
@@ -32,6 +32,8 @@ src_unpack() {
# Add in support for mpeg3split
epatch ${FILESDIR}/${PV}-gentoo-mpeg3split.patch
epatch ${FILESDIR}/${PV}-pthread.patch
+ [ ${ARCH} = ppc ] && epatch ${FILESDIR}/${PV}-ppc-largefile.patch
+ epatch ${FILESDIR}/${PV}-proper-c.patch
}
src_compile() {