summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-23 23:14:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-23 23:14:07 +0000
commit0e85cbd9fddbc58a695fa7b34c371de616bb35c1 (patch)
treea4e184bf3ddedf0c49b40993e8906aafdd846769 /media-libs/libpng
parentAdd patch to fix compilation with gcc-4; bug #113102, thanks to tiger683 AT g... (diff)
downloadgentoo-2-0e85cbd9fddbc58a695fa7b34c371de616bb35c1.tar.gz
gentoo-2-0e85cbd9fddbc58a695fa7b34c371de616bb35c1.tar.bz2
gentoo-2-0e85cbd9fddbc58a695fa7b34c371de616bb35c1.zip
touchup how we link so --as-needed works #116459
(Portage version: 2.0.53)
Diffstat (limited to 'media-libs/libpng')
-rw-r--r--media-libs/libpng/files/libpng-1.2.8-build.patch22
-rw-r--r--media-libs/libpng/libpng-1.2.8-r1.ebuild3
2 files changed, 15 insertions, 10 deletions
diff --git a/media-libs/libpng/files/libpng-1.2.8-build.patch b/media-libs/libpng/files/libpng-1.2.8-build.patch
index f1161d506b73..ff72b0bf57fb 100644
--- a/media-libs/libpng/files/libpng-1.2.8-build.patch
+++ b/media-libs/libpng/files/libpng-1.2.8-build.patch
@@ -32,8 +32,8 @@ Clean up build system to make cross-compiling easy
+LDFLAGS += -L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB)
+endif
+LDFLAGS += -lz -lm
-+LDFLAGS_A = $(LDFLAGS) libpng.a
-+LDFLAGS_SO = $(LDFLAGS) -L. -Wl,-rpath,. -lpng12
++LDFLAGS_A = libpng.a $(LDFLAGS)
++LDFLAGS_SO = -L. -Wl,-rpath,. -lpng12 $(LDFLAGS)
-LDFLAGS=-L. -Wl,-rpath,. -L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) -lpng12 -lz -lm
-LDFLAGS_A=-L$(ZLIBLIB) -Wl,-rpath,$(ZLIBLIB) libpng.a -lz -lm
@@ -59,7 +59,13 @@ Clean up build system to make cross-compiling easy
$(RANLIB) $@
libpng.pc:
-@@ -104,10 +111,10 @@
+@@ -99,15 +106,15 @@
+ $(LIBNAME).so.$(PNGVER): $(OBJSDLL)
+ $(CC) -shared -Wl,-soname,$(LIBNAME).so.$(PNGMAJ) \
+ -o $(LIBNAME).so.$(PNGVER) \
+- $(OBJSDLL)
++ $(OBJSDLL) $(LDFLAGS)
+
libpng.so.3.$(PNGMIN): $(OBJSDLL)
$(CC) -shared -Wl,-soname,libpng.so.3 \
-o libpng.so.3.$(PNGMIN) \
@@ -72,8 +78,8 @@ Clean up build system to make cross-compiling easy
pngtest-static: pngtest.o libpng.a
$(CC) -o pngtest-static $(CFLAGS) pngtest.o $(LDFLAGS_A)
---- scripts/makefile.darwin 2005-10-30 09:55:21.000000000 +0100
-+++ scripts/makefile.darwin 2005-10-30 10:08:38.000000000 +0100
+--- scripts/makefile.darwin
++++ scripts/makefile.darwin
@@ -7,20 +7,30 @@
# For conditions of distribution and use, see copyright notice in png.h
@@ -84,10 +90,8 @@ Clean up build system to make cross-compiling easy
# Where the zlib library and include files are located
#ZLIBLIB=/usr/local/lib
#ZLIBINC=/usr/local/include
--ZLIBLIB=../zlib
--ZLIBINC=../zlib
-+ZLIBLIB=./zlib
-+ZLIBINC=./zlib
+ ZLIBLIB=../zlib
+ ZLIBINC=../zlib
-CC=cc
-CFLAGS=-I$(ZLIBINC) -Wall -O3 -funroll-loops
diff --git a/media-libs/libpng/libpng-1.2.8-r1.ebuild b/media-libs/libpng/libpng-1.2.8-r1.ebuild
index 07660c681935..f01cbe275709 100644
--- a/media-libs/libpng/libpng-1.2.8-r1.ebuild
+++ b/media-libs/libpng/libpng-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.8-r1.ebuild,v 1.1 2005/10/11 00:43:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.8-r1.ebuild,v 1.2 2005/12/23 23:14:07 vapier Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -22,6 +22,7 @@ src_unpack() {
use doc && cp "${DISTDIR}"/libpng-manual.txt .
epatch "${FILESDIR}"/1.2.7-gentoo.diff
+ cp scripts/makefile.linux{,.orig}
epatch "${FILESDIR}"/${PN}-1.2.8-strnlen.patch
epatch "${FILESDIR}"/${PN}-1.2.8-build.patch