summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-04 03:59:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-04 03:59:52 +0000
commit8637b030f748b0da0d801d48d0e995a6a40e689c (patch)
tree6932dca6552c3540e523078cfdcb455509fc41c9 /media-libs/libsdl/files
parentrebuild patch against 1.2.8 (diff)
downloadgentoo-2-8637b030f748b0da0d801d48d0e995a6a40e689c.tar.gz
gentoo-2-8637b030f748b0da0d801d48d0e995a6a40e689c.tar.bz2
gentoo-2-8637b030f748b0da0d801d48d0e995a6a40e689c.zip
Make sure libsdl doesnt link against C++ since we dont need it and cleanup sdl-config output.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/libsdl/files')
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.8-no-cxx.patch23
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.8-sdl-config.patch19
2 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libsdl/files/libsdl-1.2.8-no-cxx.patch b/media-libs/libsdl/files/libsdl-1.2.8-no-cxx.patch
new file mode 100644
index 000000000000..8689a46264a5
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.8-no-cxx.patch
@@ -0,0 +1,23 @@
+A little hack to keep C++ crap out of libsdl.
+
+Problem is that autotools isn't smart enough to realize that libarch.la
+should be linked as C++ only for TARGET_BEOS ... otherwise it should be
+linked as a good old fashioned C library.
+
+Since Gentoo doesn't support BEOS [atm], this hack is acceptable considering
+the gain (no more C++ crap !).
+
+--- src/main/Makefile.am
++++ src/main/Makefile.am
+@@ -33,11 +33,7 @@ libSDLmain_a_SOURCES = $(MAINLIB_ARCH_SR
+ # Build an internal library of any special app setup functions
+ noinst_LTLIBRARIES = libarch.la
+
+-if TARGET_BEOS
+-ARCH_SRCS = beos/SDL_BeApp.cc beos/SDL_BeApp.h
+-else
+ ARCH_SRCS = arch.c
+-endif
+
+ libarch_la_SOURCES = $(ARCH_SRCS)
+
diff --git a/media-libs/libsdl/files/libsdl-1.2.8-sdl-config.patch b/media-libs/libsdl/files/libsdl-1.2.8-sdl-config.patch
new file mode 100644
index 000000000000..a27f098859ec
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.8-sdl-config.patch
@@ -0,0 +1,19 @@
+Only output -L -rpath cruft if using a non-standard install location.
+
+Makes ABI / cross-compiling easier on the soul.
+
+--- sdl-config.in
++++ sdl-config.in
+@@ -51,7 +51,11 @@
+ #echo $includes -I@includedir@/SDL @SDL_CFLAGS@
+ ;;
+ @ENABLE_SHARED_TRUE@ --libs)
+-@ENABLE_SHARED_TRUE@ libdirs="-L@libdir@ @SDL_RLD_FLAGS@"
++@ENABLE_SHARED_TRUE@ if test x"@libdir@" != x"/usr/lib" ; then
++@ENABLE_SHARED_TRUE@ libdirs="-L@libdir@ @SDL_RLD_FLAGS@"
++@ENABLE_SHARED_TRUE@ else
++@ENABLE_SHARED_TRUE@ libdirs=""
++@ENABLE_SHARED_TRUE@ fi
+ @ENABLE_SHARED_TRUE@ echo $libdirs @SDL_LIBS@ @SHARED_SYSTEM_LIBS@
+ @ENABLE_SHARED_TRUE@ ;;
+ @ENABLE_STATIC_TRUE@@ENABLE_SHARED_TRUE@ --static-libs)