summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-03 02:19:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-03 02:19:12 +0000
commite2e99f666711debbe52fa818a9fec0f14a4d8ebf (patch)
tree1e763d7c1da8c82b5944ac0785e6571be2b2a9dd /media-libs/libsdl
parentUnppcable until ioremap fix. (Manifest recommit) (diff)
downloadgentoo-2-e2e99f666711debbe52fa818a9fec0f14a4d8ebf.tar.gz
gentoo-2-e2e99f666711debbe52fa818a9fec0f14a4d8ebf.tar.bz2
gentoo-2-e2e99f666711debbe52fa818a9fec0f14a4d8ebf.zip
Add patch from upstream to fix keyrepeating #76448 by Jon Daniel.
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog8
-rw-r--r--media-libs/libsdl/files/1.2.8-keyrepeat.patch18
-rw-r--r--media-libs/libsdl/libsdl-1.2.6-r3.ebuild4
-rw-r--r--media-libs/libsdl/libsdl-1.2.7-r3.ebuild5
-rw-r--r--media-libs/libsdl/libsdl-1.2.8.ebuild5
5 files changed, 32 insertions, 8 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 12c71c7b3a89..59637b77aa30 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.70 2005/01/01 01:20:29 kingtaco Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.71 2005/01/03 02:19:12 vapier Exp $
+
+ 02 Jan 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/1.2.8-keyrepeat.patch, libsdl-1.2.7-r3.ebuild, libsdl-1.2.8.ebuild:
+ Add patch from upstream to fix keyrepeating #76448 by Jon Daniel.
31 Dec 2004; Mike Doty <kingtaco@gentoo.org> libsdl-1.2.8.ebuild:
strip-flags -funroll-all-loops & -fpeel-loops bug #74608
diff --git a/media-libs/libsdl/files/1.2.8-keyrepeat.patch b/media-libs/libsdl/files/1.2.8-keyrepeat.patch
new file mode 100644
index 000000000000..c716b4a2a929
--- /dev/null
+++ b/media-libs/libsdl/files/1.2.8-keyrepeat.patch
@@ -0,0 +1,18 @@
+Index: SDL_keyboard.c
+===================================================================
+RCS file: /home/sdlweb/libsdl.org/cvs/SDL12/src/events/SDL_keyboard.c,v
+retrieving revision 1.9
+retrieving revision 1.10
+diff -u -r1.9 -r1.10
+--- src/events/SDL_keyboard.c 4 Jan 2004 16:49:17 -0000 1.9
++++ src/events/SDL_keyboard.c 3 Jan 2005 00:24:44 -0000 1.10
+@@ -491,7 +491,8 @@
+ /*
+ * jk 991215 - Added
+ */
+- if ( SDL_KeyRepeat.timestamp ) {
++ if ( SDL_KeyRepeat.timestamp &&
++ SDL_KeyRepeat.evt.key.keysym.sym == keysym->sym ) {
+ SDL_KeyRepeat.timestamp = 0;
+ }
+ break;
diff --git a/media-libs/libsdl/libsdl-1.2.6-r3.ebuild b/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
index c38eceff5b5c..f60e5bb39f31 100644
--- a/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.6-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r3.ebuild,v 1.11 2004/10/01 10:19:07 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.6-r3.ebuild,v 1.12 2005/01/03 02:19:12 vapier Exp $
inherit eutils
diff --git a/media-libs/libsdl/libsdl-1.2.7-r3.ebuild b/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
index 48293c122437..a81a149819db 100644
--- a/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.7-r3.ebuild,v 1.7 2004/11/16 06:34:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.7-r3.ebuild,v 1.8 2005/01/03 02:19:12 vapier Exp $
inherit toolchain-funcs fixheadtails eutils gnuconfig
@@ -51,6 +51,7 @@ src_unpack() {
&& epatch "${FILESDIR}/${PV}-gcc34.patch" #48947
epatch "${FILESDIR}/${PV}-joystick2.patch" #52833
epatch "${FILESDIR}/${PV}-26headers.patch" #58192
+ epatch "${FILESDIR}"/1.2.8-keyrepeat.patch #76448
ht_fix_file configure.in
diff --git a/media-libs/libsdl/libsdl-1.2.8.ebuild b/media-libs/libsdl/libsdl-1.2.8.ebuild
index 6e8cb1e5bd70..2dcea920f6a9 100644
--- a/media-libs/libsdl/libsdl-1.2.8.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8.ebuild,v 1.7 2005/01/01 01:20:29 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8.ebuild,v 1.8 2005/01/03 02:19:12 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils gnuconfig
@@ -49,6 +49,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}-nobuggy-X.patch #30089
epatch "${FILESDIR}"/${PV}-libcaca.patch #40224
epatch "${FILESDIR}"/${PV}-gcc2.patch #75392
+ epatch "${FILESDIR}"/${PV}-keyrepeat.patch #76448
[[ $(gcc-major-version) -eq 2 ]] && \
epatch "${FILESDIR}"/${PV}-gcc2-asm.patch #75392