summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-06 04:07:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-06 04:07:05 +0000
commitf7295a8d2e68c82f83489bf9c8bcd42c8b6d6dc6 (patch)
tree31c03c0e0d41298f7f27a92b20d287045c922606 /media-libs/libsdl
parentbumpity bump bump (Manifest recommit) (diff)
downloadgentoo-2-f7295a8d2e68c82f83489bf9c8bcd42c8b6d6dc6.tar.gz
gentoo-2-f7295a8d2e68c82f83489bf9c8bcd42c8b6d6dc6.tar.bz2
gentoo-2-f7295a8d2e68c82f83489bf9c8bcd42c8b6d6dc6.zip
stable for x86; use toolchain-funcs; tidy
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog5
-rw-r--r--media-libs/libsdl/libsdl-1.2.7-r3.ebuild23
2 files changed, 15 insertions, 13 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index cd1c4cd49c86..456ddda743d6 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.60 2004/10/01 10:19:07 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.61 2004/11/06 04:07:05 mr_bones_ Exp $
+
+ 05 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org> libsdl-1.2.7-r3.ebuild:
+ stable for x86; use toolchain-funcs; tidy
01 Oct 2004; Danny van Dyk <kugelfang@gentoo.org> libsdl-1.2.6-r3.ebuild,
libsdl-1.2.7-r1.ebuild, libsdl-1.2.7-r2.ebuild, libsdl-1.2.7-r3.ebuild,
diff --git a/media-libs/libsdl/libsdl-1.2.7-r3.ebuild b/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
index 9059f9d4f361..36e247ce6024 100644
--- a/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.7-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.7-r3.ebuild,v 1.2 2004/10/01 10:19:07 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.7-r3.ebuild,v 1.3 2004/11/06 04:07:05 mr_bones_ Exp $
-inherit fixheadtails eutils gnuconfig
+inherit toolchain-funcs fixheadtails eutils gnuconfig
DESCRIPTION="Simple Direct Media Layer"
HOMEPAGE="http://www.libsdl.org/"
@@ -10,7 +10,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick"
# if you disable audio/video/joystick and something breaks, you pick up the pieces
@@ -43,13 +43,13 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/${PV}-nobuggy-X.patch #30089
- epatch ${FILESDIR}/${PV}-libcaca.patch #40224
- epatch ${FILESDIR}/${PV}-gcc34.patch #48947
- epatch ${FILESDIR}/${PV}-joystick2.patch #52833
- epatch ${FILESDIR}/${PV}-26headers.patch #58192
+ epatch "${FILESDIR}/${PV}-nobuggy-X.patch" #30089
+ epatch "${FILESDIR}/${PV}-libcaca.patch" #40224
+ epatch "${FILESDIR}/${PV}-gcc34.patch" #48947
+ epatch "${FILESDIR}/${PV}-joystick2.patch" #52833
+ epatch "${FILESDIR}/${PV}-26headers.patch" #58192
ht_fix_file configure.in
@@ -60,12 +60,11 @@ src_unpack() {
fi
./autogen.sh || die "autogen failed"
-
gnuconfig_update
}
src_compile() {
- local myconf=""
+ local myconf=
use noaudio && myconf="${myconf} --disable-audio"
use novideo \
&& myconf="${myconf} --disable-video" \
@@ -78,7 +77,7 @@ src_compile() {
# dependency loop, only link against DirectFB if it
# isn't broken #61592
echo 'int main(){}' > directfb-test.c
- $(gcc-getCC) directfb-test.c -ldirectfb 2>/dev/null \
+ $(tc-getCC) directfb-test.c -ldirectfb 2>/dev/null \
&& directfbconf="--enable-video-directfb" \
|| ewarn "Disabling DirectFB since libdirectfb.so is broken"
fi