summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-10 08:02:22 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-10 08:02:22 +0000
commitffd52cd0ad9fe753f9134e8e88a3227dee40da79 (patch)
treefb11dc6f7c02b9e17915024fe25bbbd271e46dd4 /media-libs/libsdl
parentBump and take over for x11 herd, since it's now become a modular xorg package. (diff)
downloadgentoo-2-ffd52cd0ad9fe753f9134e8e88a3227dee40da79.tar.gz
gentoo-2-ffd52cd0ad9fe753f9134e8e88a3227dee40da79.tar.bz2
gentoo-2-ffd52cd0ad9fe753f9134e8e88a3227dee40da79.zip
Add support for USE=pulseaudio and fixing it in the process #198147 by jon R-B / Eugene Zagidullin.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog9
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.13-pulseaudio.patch40
-rw-r--r--media-libs/libsdl/libsdl-1.2.13.ebuild11
3 files changed, 54 insertions, 6 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 09de92884751..4b2efef2cbd3 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsdl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.138 2007/12/31 15:52:00 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.139 2008/01/10 08:02:21 vapier Exp $
+
+ 10 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/libsdl-1.2.13-pulseaudio.patch, libsdl-1.2.13.ebuild:
+ Add support for USE=pulseaudio and fixing it in the process #198147 by jon
+ R-B / Eugene Zagidullin.
*libsdl-1.2.13 (31 Dec 2007)
diff --git a/media-libs/libsdl/files/libsdl-1.2.13-pulseaudio.patch b/media-libs/libsdl/files/libsdl-1.2.13-pulseaudio.patch
new file mode 100644
index 000000000000..8bbf529431cc
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.13-pulseaudio.patch
@@ -0,0 +1,40 @@
+fixup the pulse audio configure flags. this is already fixed upstream.
+
+http://bugs.gentoo.org/198147
+
+--- SDL/configure.in
++++ SDL/configure.in
+@@ -470,8 +470,8 @@
+ {
+ AC_ARG_ENABLE(pulseaudio,
+ AC_HELP_STRING([--enable-pulseaudio], [use PulseAudio [[default=yes]]]),
+- , enable_pulse=yes)
+- if test x$enable_audio = xyes -a x$enable_pulse = xyes; then
++ , enable_pulseaudio=yes)
++ if test x$enable_audio = xyes -a x$enable_pulseaudio = xyes; then
+ audio_pulse=no
+
+ PULSE_REQUIRED_VERSION=0.9
+@@ -490,7 +490,7 @@
+ if test x$audio_pulse = xyes; then
+ AC_ARG_ENABLE(pulseaudio-shared,
+ AC_HELP_STRING([--enable-pulseaudio-shared], [dynamically load PulseAudio support [[default=yes]]]),
+- , enable_pulse_shared=yes)
++ , enable_pulseaudio_shared=yes)
+ if test "x`echo $PULSE_LIBS | grep -- -L`" = "x"; then
+ if test "x`ls /lib/libpulse-simple.so.* 2> /dev/null`" != "x"; then
+ PULSE_LIBS="-L/lib $PULSE_LIBS"
+@@ -508,11 +508,11 @@
+ SOURCES="$SOURCES $srcdir/src/audio/pulse/*.c"
+ EXTRA_CFLAGS="$EXTRA_CFLAGS $PULSE_CFLAGS"
+ if test x$have_loadso != xyes && \
+- test x$enable_pulse_shared = xyes; then
++ test x$enable_pulseaudio_shared = xyes; then
+ AC_MSG_WARN([You must have SDL_LoadObject() support for dynamic PulseAudio loading])
+ fi
+ if test x$have_loadso = xyes && \
+- test x$enable_pulse_shared = xyes && test x$pulse_lib != x; then
++ test x$enable_pulseaudio_shared = xyes && test x$pulse_lib != x; then
+ AC_DEFINE_UNQUOTED(SDL_AUDIO_DRIVER_PULSE_DYNAMIC, "$pulse_lib")
+ else
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PULSE_LIBS"
diff --git a/media-libs/libsdl/libsdl-1.2.13.ebuild b/media-libs/libsdl/libsdl-1.2.13.ebuild
index 2c4c899114ea..e8b1dab927ad 100644
--- a/media-libs/libsdl/libsdl-1.2.13.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.13.ebuild,v 1.1 2007/12/31 15:52:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.13.ebuild,v 1.2 2008/01/10 08:02:21 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -15,7 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-
# if you have the noaudio, novideo, nojoystick, or custom-cflags use flags
# in USE and something breaks, you pick up the pieces. Be prepared for
# bug reports to be marked INVALID.
-IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick custom-cflags"
+IUSE="oss alsa esd arts nas X dga xv xinerama fbcon directfb ggi svga aalib opengl libcaca noaudio novideo nojoystick custom-cflags pulseaudio"
RDEPEND="!noaudio? ( >=media-libs/audiofile-0.1.9 )
alsa? ( media-libs/alsa-lib )
@@ -38,7 +38,8 @@ RDEPEND="!noaudio? ( >=media-libs/audiofile-0.1.9 )
svga? ( >=media-libs/svgalib-1.4.2 )
aalib? ( media-libs/aalib )
libcaca? ( >=media-libs/libcaca-0.9-r1 )
- opengl? ( virtual/opengl virtual/glu )"
+ opengl? ( virtual/opengl virtual/glu )
+ pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}
nas? (
x11-proto/xextproto
@@ -75,6 +76,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.2.11-libcaca-new-api.patch #40224
epatch "${FILESDIR}"/${PN}-1.2.11-sdl-config.patch
epatch "${FILESDIR}"/${PN}-1.2.11-xinerama-head-0.patch #145917
+ epatch "${FILESDIR}"/${P}-pulseaudio.patch #198147
./autogen.sh || die "autogen failed"
elibtoolize
@@ -120,6 +122,7 @@ src_compile() {
$(use_enable oss) \
$(use_enable alsa) \
$(use_enable esd) \
+ $(use_enable pulseaudio) \
$(use_enable arts) \
$(use_enable nas) \
$(use_enable X video-x11) \