summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-11-17 22:06:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-11-17 22:06:33 +0000
commit95ca3bbbefeddee744a17d3410912ce9dbd16aa8 (patch)
treeed717cd5df10d76e03c693a3d1e1cc28a04df701 /media-libs/libsndfile/libsndfile-1.0.11.ebuild
parentStable amd64, sparc, x86. (Manifest recommit) (diff)
downloadgentoo-2-95ca3bbbefeddee744a17d3410912ce9dbd16aa8.tar.gz
gentoo-2-95ca3bbbefeddee744a17d3410912ce9dbd16aa8.tar.bz2
gentoo-2-95ca3bbbefeddee744a17d3410912ce9dbd16aa8.zip
Version bump and cleanup.
Diffstat (limited to 'media-libs/libsndfile/libsndfile-1.0.11.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/libsndfile/libsndfile-1.0.11.ebuild b/media-libs/libsndfile/libsndfile-1.0.11.ebuild
new file mode 100644
index 000000000000..a3f121c307ec
--- /dev/null
+++ b/media-libs/libsndfile/libsndfile-1.0.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.11.ebuild,v 1.1 2004/11/17 22:06:33 eradicator Exp $
+
+IUSE="static"
+
+DESCRIPTION="A C library for reading and writing files containing sampled sound"
+HOMEPAGE="http://www.mega-nerd.com/libsndfile/"
+SRC_URI="http://www.mega-nerd.com/libsndfile/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf $(use_enable static) || die "./configure failed"
+
+ # fix this weird doc installation directory libsndfile decides
+ # to something more standard
+ sed -e "s:^htmldocdir.*:htmldocdir = /usr/share/doc/${PF}/html:" -i ${S}/doc/Makefile
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}