summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-22 13:27:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-22 13:27:43 +0000
commitc424668cf58f54048249d11f3f94f1d3f82a35ba (patch)
tree4d46376355609a444f2766561a5866edfd98cf8e /media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
parentDon't build tests and examples during standard make, this saves a few gcc/ld ... (diff)
downloadgentoo-2-c424668cf58f54048249d11f3f94f1d3f82a35ba.tar.gz
gentoo-2-c424668cf58f54048249d11f3f94f1d3f82a35ba.tar.bz2
gentoo-2-c424668cf58f54048249d11f3f94f1d3f82a35ba.zip
Don't build tests and examples during standard make, this saves a few gcc/ld calls for most users. Don't build regtest if sqlite is disabled, rather than just removing it after the fact. Don't request old version of automake, as full eautoreconf is called.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild')
-rw-r--r--media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild b/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
index 7c3e8a40ee76..947879d7a0d6 100644
--- a/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
+++ b/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild
@@ -1,9 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild,v 1.11 2008/02/15 17:16:55 mr_bones_ Exp $
-
-WANT_AUTOCONF=2.5
-WANT_AUTOMAKE=1.9
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsndfile/libsndfile-1.0.17-r1.ebuild,v 1.12 2008/02/22 13:27:43 flameeyes Exp $
inherit eutils libtool autotools
@@ -32,6 +29,8 @@ src_unpack() {
epatch "${WORKDIR}/${P}+flac-1.1.3.patch"
epatch "${FILESDIR}/${P}-ogg.patch"
epatch "${FILESDIR}/${P}-flac-buffer-overflow.patch"
+ epatch "${FILESDIR}/${P}-dontbuild-tests-examples.patch"
+ epatch "${FILESDIR}/${P}-regtests-need-sqlite.patch"
eautoreconf
epunt_cxx
}
@@ -49,7 +48,4 @@ src_compile() {
src_install() {
emake -j1 DESTDIR="${D}" htmldocdir="/usr/share/doc/${PF}/html" install || die "emake install failed."
dodoc AUTHORS ChangeLog NEWS README TODO
- # Only prints following message: "This program was not compiled
- # with libsqlite3 and hence doesn't work." wrt bug #210161.
- use sqlite || rm -f "${D}"/usr/bin/sndfile-regtest
}