summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-03 05:50:52 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-03 05:50:52 +0000
commit034055be0a5087a83cfd5fe014dd5534a25265ac (patch)
tree8661ceddbe1de0e2e06d31c0ccaf836aa2636bb6 /media-libs/libsoundtouch
parentUse generic pkg-config (diff)
downloadgentoo-2-034055be0a5087a83cfd5fe014dd5534a25265ac.tar.gz
gentoo-2-034055be0a5087a83cfd5fe014dd5534a25265ac.tar.bz2
gentoo-2-034055be0a5087a83cfd5fe014dd5534a25265ac.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/libsoundtouch')
-rw-r--r--media-libs/libsoundtouch/ChangeLog9
-rw-r--r--media-libs/libsoundtouch/libsoundtouch-1.7.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/media-libs/libsoundtouch/ChangeLog b/media-libs/libsoundtouch/ChangeLog
index c6cd54847eb2..a083c2e1cc6b 100644
--- a/media-libs/libsoundtouch/ChangeLog
+++ b/media-libs/libsoundtouch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsoundtouch
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.62 2012/11/29 15:11:43 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/ChangeLog,v 1.63 2013/01/03 05:50:52 radhermit Exp $
+
+*libsoundtouch-1.7.1 (03 Jan 2013)
+
+ 03 Jan 2013; Tim Harder <radhermit@gentoo.org> +libsoundtouch-1.7.1.ebuild:
+ Version bump.
29 Nov 2012; Jeroen Roovers <jer@gentoo.org> libsoundtouch-1.7.0.ebuild:
Stable for HPPA (bug #441378).
diff --git a/media-libs/libsoundtouch/libsoundtouch-1.7.1.ebuild b/media-libs/libsoundtouch/libsoundtouch-1.7.1.ebuild
new file mode 100644
index 000000000000..935fbbf1562a
--- /dev/null
+++ b/media-libs/libsoundtouch/libsoundtouch-1.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsoundtouch/libsoundtouch-1.7.1.ebuild,v 1.1 2013/01/03 05:50:52 radhermit Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+MY_PN=${PN/lib}
+
+DESCRIPTION="Audio processing library for changing tempo, pitch and playback rates."
+HOMEPAGE="http://www.surina.net/soundtouch/"
+SRC_URI="http://www.surina.net/soundtouch/${P/lib}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="sse2 static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.0-flags.patch
+ sed -i -e "s:^\(pkgdoc_DATA=\)COPYING.TXT :\1:" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-integer-samples \
+ --enable-x86-optimizations=$(usex sse2) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF}/html install
+ prune_libtool_files
+}