summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-11 03:02:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-11 03:02:28 +0000
commit4e3b1e4d7894273ca65e1b5c8a53ea940f353aa4 (patch)
tree0ed80167b3c79f0f829f014a7a6b9a62d7b12dcf /media-libs/libtheora
parentadd missing rdepends per bug #457036 (diff)
downloadgentoo-2-4e3b1e4d7894273ca65e1b5c8a53ea940f353aa4.tar.gz
gentoo-2-4e3b1e4d7894273ca65e1b5c8a53ea940f353aa4.tar.bz2
gentoo-2-4e3b1e4d7894273ca65e1b5c8a53ea940f353aa4.zip
Fix building of png2theora with libpng16 wrt #465450 by Billy DeVincentis
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch16
-rw-r--r--media-libs/libtheora/libtheora-1.1.1.ebuild48
3 files changed, 46 insertions, 24 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 7c18ae88b90b..518127e5e796 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.108 2013/02/22 15:51:11 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.109 2013/04/11 03:02:28 ssuominen Exp $
+
+ 11 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> libtheora-1.1.1.ebuild,
+ +files/libtheora-1.1.1-libpng16.patch:
+ Fix building of png2theora with libpng16 wrt #465450 by Billy DeVincentis
22 Feb 2013; Zac Medico <zmedico@gentoo.org> libtheora-1.1.1.ebuild:
Fix for prefix, add ~arm-linux keyword, and merge KEYWORDS from the
diff --git a/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch b/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch
new file mode 100644
index 000000000000..883cb91465c0
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.1.1-libpng16.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/465450
+
+--- examples/png2theora.c
++++ examples/png2theora.c
+@@ -462,9 +462,9 @@
+ png_set_strip_alpha(png_ptr);
+
+ row_data = (png_bytep)png_malloc(png_ptr,
+- 3*height*width*png_sizeof(*row_data));
++ 3*height*width*sizeof(*row_data));
+ row_pointers = (png_bytep *)png_malloc(png_ptr,
+- height*png_sizeof(*row_pointers));
++ height*sizeof(*row_pointers));
+ for(y = 0; y < height; y++) {
+ row_pointers[y] = row_data + y*(3*width);
+ }
diff --git a/media-libs/libtheora/libtheora-1.1.1.ebuild b/media-libs/libtheora/libtheora-1.1.1.ebuild
index 4e675f19d9be..a0baee0d4a9c 100644
--- a/media-libs/libtheora/libtheora-1.1.1.ebuild
+++ b/media-libs/libtheora/libtheora-1.1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1.ebuild,v 1.11 2013/02/22 15:51:11 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1.1.ebuild,v 1.12 2013/04/11 03:02:28 ssuominen Exp $
-EAPI=3
+EAPI=5
inherit autotools eutils flag-o-matic
DESCRIPTION="The Theora Video Compression Codec"
@@ -14,46 +14,48 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~ppc-aix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="doc +encode examples static-libs"
-RDEPEND="media-libs/libogg
- encode? ( media-libs/libvorbis )
- examples? ( media-libs/libpng
- media-libs/libvorbis
- >=media-libs/libsdl-0.11.0 )"
+RDEPEND="media-libs/libogg:=
+ encode? ( media-libs/libvorbis:= )
+ examples? (
+ media-libs/libpng:0=
+ >=media-libs/libsdl-0.11.0
+ media-libs/libvorbis:=
+ )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
virtual/pkgconfig"
+REQUIRED_USE="examples? ( encode )" #285895
-VARTEXFONTS=${T}/fonts
S=${WORKDIR}/${P/_}
+VARTEXFONTS=${T}/fonts
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
- AT_M4DIR="m4" eautoreconf
+ epatch \
+ "${FILESDIR}"/${PN}-1.0_beta2-flags.patch \
+ "${FILESDIR}"/${P}-libpng16.patch #465450
+ AT_M4DIR=m4 eautoreconf
}
src_configure() {
use x86 && filter-flags -fforce-addr -frename-registers #200549
- use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
-
- local myconf
- use examples && myconf="--enable-encode"
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
# --disable-spec because LaTeX documentation has been prebuilt
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static) \
--disable-spec \
$(use_enable encode) \
- $(use_enable examples) \
- ${myconf}
+ $(use_enable examples)
}
src_install() {
- emake DESTDIR="${D}" docdir="${EPREFIX}"/usr/share/doc/${PF} \
- install || die "emake install failed"
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
dodoc AUTHORS CHANGES README
- prepalldocs
if use examples; then
if use doc; then
@@ -61,11 +63,11 @@ src_install() {
doins examples/*.[ch]
fi
- dobin examples/.libs/png2theora || die "dobin failed"
+ dobin examples/.libs/png2theora
for bin in dump_{psnr,video} {encoder,player}_example; do
- newbin examples/.libs/${bin} theora_${bin} || die "newbin failed"
+ newbin examples/.libs/${bin} theora_${bin}
done
fi
- find "${ED}" -name '*.la' -exec rm -f '{}' +
+ prune_libtool_files
}