summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-30 14:38:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-30 14:38:01 +0000
commitab48ab8b9e7be2f3acce4c4ac72193dc6d94be9c (patch)
tree7d736fd316bc6eb2ae2105403f9fc4c449a7232d /media-libs/libtheora
parentDon't block libjingle, remove relayserver and stunserver. (diff)
downloadgentoo-2-ab48ab8b9e7be2f3acce4c4ac72193dc6d94be9c.tar.gz
gentoo-2-ab48ab8b9e7be2f3acce4c4ac72193dc6d94be9c.tar.bz2
gentoo-2-ab48ab8b9e7be2f3acce4c4ac72193dc6d94be9c.zip
Apply patch for PIC compatibility on x86 architecture, thanks to PaX Team. Closes bug #142182.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog10
-rw-r--r--media-libs/libtheora/files/digest-libtheora-1.0_alpha6-r13
-rw-r--r--media-libs/libtheora/files/libtheora-1.0_alpha6-pic-fix.patch166
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha6-r1.ebuild70
4 files changed, 248 insertions, 1 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 8acc44631e66..5416b5eed475 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.40 2006/06/08 17:54:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.41 2006/07/30 14:38:01 flameeyes Exp $
+
+*libtheora-1.0_alpha6-r1 (30 Jul 2006)
+
+ 30 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libtheora-1.0_alpha6-pic-fix.patch,
+ +libtheora-1.0_alpha6-r1.ebuild:
+ Apply patch for PIC compatibility on x86 architecture, thanks to PaX Team.
+ Closes bug #142182.
08 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
libtheora-1.0_alpha6.ebuild:
diff --git a/media-libs/libtheora/files/digest-libtheora-1.0_alpha6-r1 b/media-libs/libtheora/files/digest-libtheora-1.0_alpha6-r1
new file mode 100644
index 000000000000..5beb4076a158
--- /dev/null
+++ b/media-libs/libtheora/files/digest-libtheora-1.0_alpha6-r1
@@ -0,0 +1,3 @@
+MD5 ff8d0c112fdab66930acf42c423d2536 libtheora-1.0alpha6.tar.bz2 1559318
+RMD160 b0d81dab81ec96d51e2d6a4c047beff807de6077 libtheora-1.0alpha6.tar.bz2 1559318
+SHA256 4e6044cb24d2cdb42e5d9402c709644886e8761f7b166781469ffda44240da92 libtheora-1.0alpha6.tar.bz2 1559318
diff --git a/media-libs/libtheora/files/libtheora-1.0_alpha6-pic-fix.patch b/media-libs/libtheora/files/libtheora-1.0_alpha6-pic-fix.patch
new file mode 100644
index 000000000000..d79d67afe38d
--- /dev/null
+++ b/media-libs/libtheora/files/libtheora-1.0_alpha6-pic-fix.patch
@@ -0,0 +1,166 @@
+diff -urp libtheora-1.0alpha6-old/lib/x86_32/dsp_mmx.c libtheora-1.0alpha6/lib/x86_32/dsp_mmx.c
+--- libtheora-1.0alpha6-old/lib/x86_32/dsp_mmx.c 2006-05-27 19:09:12.000000000 +0200
++++ libtheora-1.0alpha6/lib/x86_32/dsp_mmx.c 2006-07-29 17:37:35.000000000 +0200
+@@ -79,7 +79,7 @@ static void sub8x8_128__mmx (unsigned ch
+ " .balign 16 \n\t"
+
+ " pxor %%mm7, %%mm7 \n\t"
+- " movq "M(V128)", %%mm1 \n\t"
++ " movq %3, %%mm1 \n\t"
+
+ ".rept 8 \n\t"
+ " movq (%0), %%mm0 \n\t" /* mm0 = FiltPtr */
+@@ -99,7 +99,8 @@ static void sub8x8_128__mmx (unsigned ch
+
+ : "+r" (FiltPtr),
+ "+r" (DctInputPtr)
+- : "m" (PixelsPerLine)
++ : "m" (PixelsPerLine),
++ "m" (V128)
+ : "memory"
+ );
+ }
+diff -urp libtheora-1.0alpha6-old/lib/x86_32/fdct_mmx.c libtheora-1.0alpha6/lib/x86_32/fdct_mmx.c
+--- libtheora-1.0alpha6-old/lib/x86_32/fdct_mmx.c 2006-05-27 19:09:12.000000000 +0200
++++ libtheora-1.0alpha6/lib/x86_32/fdct_mmx.c 2006-07-29 17:52:20.000000000 +0200
+@@ -74,7 +74,7 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm2, %%mm0 \n\t" /* make a copy */ \
+ " paddsw %%mm2, %%mm3 \n\t" /* mm3 = is0734 + is1256 */ \
+ \
+- " pmulhw "M(xC4S4)", %%mm0 \n\t" /* mm0 = xC4S4 * ( is0734 - is1256 ) - ( is0734 - is1256 ) */ \
++ " pmulhw %6, %%mm0 \n\t" /* mm0 = xC4S4 * ( is0734 - is1256 ) - ( is0734 - is1256 ) */ \
+ " paddw %%mm2, %%mm0 \n\t" /* mm0 = xC4S4 * ( is0734 - is1256 ) */ \
+ " psrlw $15, %%mm2 \n\t" \
+ " paddw %%mm2, %%mm0 \n\t" /* Truncate mm0, now it is op[4] */ \
+@@ -83,7 +83,7 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm0," #ip4 " \n\t" /* save ip4, now mm0,mm2 are free */ \
+ \
+ " movq %%mm3, %%mm0 \n\t" \
+- " pmulhw "M(xC4S4)", %%mm3 \n\t" /* mm3 = xC4S4 * ( is0734 +is1256 ) - ( is0734 +is1256 ) */ \
++ " pmulhw %6, %%mm3 \n\t" /* mm3 = xC4S4 * ( is0734 +is1256 ) - ( is0734 +is1256 ) */ \
+ \
+ " psrlw $15, %%mm2 \n\t" \
+ " paddw %%mm0, %%mm3 \n\t" /* mm3 = xC4S4 * ( is0734 +is1256 ) */ \
+@@ -92,7 +92,7 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm3," #ip0 " \n\t" \
+ /* ------------------------------------------------------------------- */ \
+ " movq " #temp ", %%mm3 \n\t" /* mm3 = irot_input_y */ \
+- " pmulhw "M(xC2S6)", %%mm3 \n\t" /* mm3 = xC2S6 * irot_input_y - irot_input_y */ \
++ " pmulhw %4, %%mm3 \n\t" /* mm3 = xC2S6 * irot_input_y - irot_input_y */ \
+ \
+ " movq " #temp ", %%mm2 \n\t" \
+ " movq %%mm2, %%mm0 \n\t" \
+@@ -104,7 +104,7 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm5, %%mm0 \n\t" \
+ \
+ " movq %%mm5, %%mm2 \n\t" \
+- " pmulhw "M(xC6S2)", %%mm0 \n\t" /* mm0 = xC6S2 * irot_input_x */ \
++ " pmulhw %8, %%mm0 \n\t" /* mm0 = xC6S2 * irot_input_x */ \
+ \
+ " psrlw $15, %%mm2 \n\t" \
+ " paddw %%mm2, %%mm0 \n\t" /* Truncated */ \
+@@ -115,7 +115,7 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm5, %%mm0 \n\t" \
+ " movq %%mm5, %%mm2 \n\t" \
+ \
+- " pmulhw "M(xC2S6)", %%mm5 \n\t" /* mm5 = xC2S6 * irot_input_x - irot_input_x */ \
++ " pmulhw %4, %%mm5 \n\t" /* mm5 = xC2S6 * irot_input_x - irot_input_x */ \
+ " psrlw $15, %%mm2 \n\t" \
+ \
+ " movq " #temp ", %%mm3 \n\t" \
+@@ -124,7 +124,7 @@ static const __attribute__ ((aligned(8),
+ " paddw %%mm2, %%mm5 \n\t" /* Truncated */ \
+ " movq %%mm3, %%mm2 \n\t" \
+ \
+- " pmulhw "M(xC6S2)", %%mm3 \n\t" /* mm3 = xC6S2 * irot_input_y */ \
++ " pmulhw %8, %%mm3 \n\t" /* mm3 = xC6S2 * irot_input_y */ \
+ " psrlw $15, %%mm2 \n\t" \
+ \
+ " paddw %%mm2, %%mm3 \n\t" /* Truncated */ \
+@@ -132,7 +132,7 @@ static const __attribute__ ((aligned(8),
+ \
+ " movq %%mm3," #ip6 " \n\t" \
+ /* ------------------------------------------------------------------- */ \
+- " movq "M(xC4S4)", %%mm0 \n\t" \
++ " movq %6, %%mm0 \n\t" \
+ " movq %%mm1, %%mm2 \n\t" \
+ " movq %%mm1, %%mm3 \n\t" \
+ \
+@@ -162,13 +162,13 @@ static const __attribute__ ((aligned(8),
+ " paddsw %%mm1, %%mm1 \n\t" \
+ " paddsw %%mm4, %%mm1 \n\t" /* mm1 = id07 + icommon_product1 */ \
+ /* ------------------------------------------------------------------- */ \
+- " movq "M(xC1S7)", %%mm7 \n\t" \
++ " movq %3, %%mm7 \n\t" \
+ " movq %%mm1, %%mm2 \n\t" \
+ \
+ " movq %%mm1, %%mm3 \n\t" \
+ " pmulhw %%mm7, %%mm1 \n\t" /* mm1 = xC1S7 * irot_input_x - irot_input_x */ \
+ \
+- " movq "M(xC7S1)", %%mm7 \n\t" \
++ " movq %9, %%mm7 \n\t" \
+ " psrlw $15, %%mm2 \n\t" \
+ \
+ " paddw %%mm3, %%mm1 \n\t" /* mm1 = xC1S7 * irot_input_x */ \
+@@ -180,10 +180,10 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm0, %%mm5 \n\t" \
+ " movq %%mm0, %%mm2 \n\t" \
+ \
+- " movq "M(xC1S7)", %%mm7 \n\t" \
++ " movq %3, %%mm7 \n\t" \
+ " pmulhw %%mm7, %%mm0 \n\t" /* mm0 = xC1S7 * irot_input_y - irot_input_y */ \
+ \
+- " movq "M(xC7S1)", %%mm7 \n\t" \
++ " movq %9, %%mm7 \n\t" \
+ " psrlw $15, %%mm2 \n\t" \
+ \
+ " paddw %%mm5, %%mm0 \n\t" /* mm0 = xC1S7 * irot_input_y */ \
+@@ -198,8 +198,8 @@ static const __attribute__ ((aligned(8),
+ " movq %%mm1," #ip1 " \n\t" \
+ " movq %%mm3," #ip7 " \n\t" \
+ /* ------------------------------------------------------------------- */ \
+- " movq "M(xC3S5)", %%mm0 \n\t" \
+- " movq "M(xC5S3)", %%mm1 \n\t" \
++ " movq %5, %%mm0 \n\t" \
++ " movq %7, %%mm1 \n\t" \
+ \
+ " movq %%mm6, %%mm5 \n\t" \
+ " movq %%mm6, %%mm7 \n\t" \
+@@ -320,7 +320,14 @@ static void fdct_short__mmx ( ogg_int16_
+
+ : "+r" (InputData),
+ "+r" (OutputData)
+- : "r" (temp)
++ : "r" (temp),
++ "m" (xC1S7),
++ "m" (xC2S6),
++ "m" (xC3S5),
++ "m" (xC4S4),
++ "m" (xC5S3),
++ "m" (xC6S2),
++ "m" (xC7S1)
+ : "memory"
+ );
+ }
+diff -urp libtheora-1.0alpha6-old/lib/x86_32/recon_mmx.c libtheora-1.0alpha6/lib/x86_32/recon_mmx.c
+--- libtheora-1.0alpha6-old/lib/x86_32/recon_mmx.c 2006-05-27 19:09:12.000000000 +0200
++++ libtheora-1.0alpha6/lib/x86_32/recon_mmx.c 2006-07-29 17:39:05.000000000 +0200
+@@ -71,7 +71,7 @@ static void recon_intra8x8__mmx (unsigne
+ __asm__ __volatile__ (
+ " .balign 16 \n\t"
+
+- " movq "M(V128)", %%mm0 \n\t" /* Set mm0 to 0x8080808080808080 */
++ " movq %3, %%mm0 \n\t" /* Set mm0 to 0x8080808080808080 */
+
+ " lea 128(%1), %%edi \n\t" /* Endpoint in input buffer */
+ "1: \n\t"
+@@ -89,7 +89,8 @@ static void recon_intra8x8__mmx (unsigne
+ " jc 1b \n\t" /* Loop back if we are not done */
+ : "+r" (ReconPtr)
+ : "r" (ChangePtr),
+- "r" (LineStep)
++ "r" (LineStep),
++ "m" (V128)
+ : "memory", "edi"
+ );
+ }
diff --git a/media-libs/libtheora/libtheora-1.0_alpha6-r1.ebuild b/media-libs/libtheora/libtheora-1.0_alpha6-r1.ebuild
new file mode 100644
index 000000000000..604bfdcede0b
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha6-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha6-r1.ebuild,v 1.1 2006/07/30 14:38:01 flameeyes Exp $
+
+inherit flag-o-matic libtool autotools
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="encode doc examples"
+
+RDEPEND=">=media-libs/libogg-1.1.0
+ encode? ( >=media-libs/libvorbis-1.0.1 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.am
+
+ epatch "${FILESDIR}/${P/_/}-buildfixes.patch"
+ epatch "${FILESDIR}/${P}-pic-fix.patch"
+
+ # Force automake 1.9 for newer autoconf
+ WANT_AUTOMAKE="1.9" \
+ AT_M4DIR="m4" eautoreconf
+
+ elibtoolize
+
+ if use examples; then
+ # This creates a clean copy of examples sources
+ cp -R "${S}/examples" "${WORKDIR}"
+ rm -f "${WORKDIR}/examples/Makefile"*
+ fi
+}
+
+src_compile() {
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf \
+ $(use_enable encode) \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="usr/share/doc/${PF}" \
+ install || die "make install failed"
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins "${WORKDIR}/examples/"*
+ fi
+
+ dodoc README
+}