summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-30 09:38:11 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-30 09:38:11 +0000
commit77b2ca03df0d1f37df23765fd939cb4ef946ed1b (patch)
treeda21ba72c547537eb063bb51ad2efaedd8bbbc50 /media-libs/libungif/libungif-4.1.3.ebuild
parentget_libdir (Manifest recommit) (diff)
downloadgentoo-2-77b2ca03df0d1f37df23765fd939cb4ef946ed1b.tar.gz
gentoo-2-77b2ca03df0d1f37df23765fd939cb4ef946ed1b.tar.bz2
gentoo-2-77b2ca03df0d1f37df23765fd939cb4ef946ed1b.zip
Version bumped. This closes bug #61240.
Diffstat (limited to 'media-libs/libungif/libungif-4.1.3.ebuild')
-rw-r--r--media-libs/libungif/libungif-4.1.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/libungif/libungif-4.1.3.ebuild b/media-libs/libungif/libungif-4.1.3.ebuild
new file mode 100644
index 000000000000..0b58e22c9345
--- /dev/null
+++ b/media-libs/libungif/libungif-4.1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libungif/libungif-4.1.3.ebuild,v 1.1 2004/09/30 09:38:11 usata Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="A library for reading and writing gif images without LZW compression"
+HOMEPAGE="http://sourceforge.net/projects/libungif/"
+SRC_URI="mirror://sourceforge/libungif/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~ppc-macos"
+IUSE="X gif"
+
+RDEPEND="X? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.57"
+
+src_compile() {
+ elibtoolize || die
+
+ local myconf
+ use alpha && myconf="${myconf} --host=alpha-unknown-linux-gnu"
+ econf `use_with X x` ${myconf} || die
+ emake -j1 || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+
+ use gif && rm -rf "${D}/usr/bin" "${D}/usr/include/gif_lib.h"
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS ONEWS UNCOMPRESSED_GIF \
+ README TODO doc/*.txt || die "dodoc failed"
+ dohtml -r doc || die "dohtml failed"
+}
+
+pkg_postinst() {
+ if use gif ; then
+ einfo "You had the gif USE flag set, so it is assumed that you want"
+ einfo "the binary from giflib instead. Please make sure you have"
+ einfo "giflib emerged. Otherwise, unset the gif flag and remerge this"
+ else
+ einfo "You did not have the gif USE flag, so your gif binary is being"
+ einfo "provided by this package. If you would rather use the binary"
+ einfo "from giflib, please set the gif USE flag, and re-emerge both"
+ einfo "this and giflib"
+ fi
+}