summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-25 18:45:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-25 18:45:40 +0000
commitbdd9a57c292c793443045ab7846b3b6f836260c8 (patch)
tree4248d78ef8d349cc0f5224131569a9b024469fb1 /media-libs/libvpx
parentStable for amd64, wrt bug #474250 (diff)
downloadgentoo-2-bdd9a57c292c793443045ab7846b3b6f836260c8.tar.gz
gentoo-2-bdd9a57c292c793443045ab7846b3b6f836260c8.tar.bz2
gentoo-2-bdd9a57c292c793443045ab7846b3b6f836260c8.zip
provide a testdata tarball so that it doesnt try to redownload them in src_test
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/libvpx')
-rw-r--r--media-libs/libvpx/ChangeLog6
-rw-r--r--media-libs/libvpx/libvpx-9999.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/media-libs/libvpx/ChangeLog b/media-libs/libvpx/ChangeLog
index 6682d4241784..fd2405c7b24d 100644
--- a/media-libs/libvpx/ChangeLog
+++ b/media-libs/libvpx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libvpx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.88 2013/06/25 18:35:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.89 2013/06/25 18:45:40 aballier Exp $
+
+ 25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
+ provide a testdata tarball so that it doesnt try to redownload them in
+ src_test
25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
do not mess with MAKEOPTS, pass it to emake directly
diff --git a/media-libs/libvpx/libvpx-9999.ebuild b/media-libs/libvpx/libvpx-9999.ebuild
index cda89a63111a..97af3119959e 100644
--- a/media-libs/libvpx/libvpx-9999.ebuild
+++ b/media-libs/libvpx/libvpx-9999.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.39 2013/06/25 18:35:40 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-9999.ebuild,v 1.40 2013/06/25 18:45:40 aballier Exp $
EAPI=4
inherit multilib toolchain-funcs multilib-minimal
+LIBVPX_TESTDATA_VER=1.2.0
+
if [[ ${PV} == *9999* ]]; then
inherit git-2
EGIT_REPO_URI="http://git.chromium.org/webm/${PN}.git"
@@ -17,6 +19,8 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}-v${PV}"
fi
+SRC_URI="${SRC_URI}
+ test? ( mirror://gentoo/${PN}-testdata-${LIBVPX_TESTDATA_VER}.tar.bz2 )"
DESCRIPTION="WebM VP8 Codec SDK"
HOMEPAGE="http://www.webmproject.org"
@@ -95,7 +99,10 @@ multilib_src_compile() {
emake verbose=yes GEN_EXAMPLES=
}
+multilib_src_test() {
+ emake verbose=yes GEN_EXAMPLES= LIBVPX_TEST_DATA_PATH="${WORKDIR}/${PN}-testdata" test
+}
+
multilib_src_install() {
emake verbose=yes GEN_EXAMPLES= DESTDIR="${D}" install
}
-