summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-04-27 07:17:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-04-27 07:17:13 +0000
commita2f54be40eee53d9361795cf365a1463de4b8a39 (patch)
tree7e1e775011b43f7b56948f6280213d3e65d9fa62 /media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild
parentStable on alpha, bug 88831. (diff)
downloadgentoo-2-a2f54be40eee53d9361795cf365a1463de4b8a39.tar.gz
gentoo-2-a2f54be40eee53d9361795cf365a1463de4b8a39.tar.bz2
gentoo-2-a2f54be40eee53d9361795cf365a1463de4b8a39.zip
Added patch to compile with gcc 4.0, fixes #90478. Revision bump because the previous was stable and this can change the behaviour on 64-bit systems.
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild')
-rw-r--r--media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild b/media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..9c7329b35c49
--- /dev/null
+++ b/media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/musicbrainz/musicbrainz-2.1.1-r1.ebuild,v 1.1 2005/04/27 07:17:13 flameeyes Exp $
+
+IUSE=""
+
+inherit eutils
+
+DESCRIPTION="Client library to access metadata of mp3/vorbis/CD media"
+HOMEPAGE="http://www.musicbrainz.org/"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/lib${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~alpha ~amd64 ~ia64 ~ppc64 ~mips"
+
+RDEPEND="dev-libs/expat"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc2.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
+src_compile() {
+ econf --enable-cpp-headers || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README TODO docs/mb_howto.txt
+}
+
+pkg_postinst() {
+ einfo "The name of the library has changed from libmusicbrainz.so.2 to libmusicbrainz.so.4."
+ einfo "If you are updating from musicbrainz-2.0.x and you want to use the new library with"
+ einfo "existing applications, you must re-emerge them by doing:"
+ einfo "revdep-rebuild --soname libmusicbrainz.so.2"
+ einfo
+ einfo "After doing that, you can safely unmerge your old version by doing:"
+ einfo "emerge unmerge \=media-libs/musicbrainz-<old version>"
+}