summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-09-02 14:35:22 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-09-02 14:35:22 +0000
commit622e4fea189441d1919471934ea567bee6c7fcfd (patch)
treef34319a1e81226142f1e085d31cff94a9f97ba8e /media-libs/openal
parenttrim whitespace (diff)
downloadgentoo-2-622e4fea189441d1919471934ea567bee6c7fcfd.tar.gz
gentoo-2-622e4fea189441d1919471934ea567bee6c7fcfd.tar.bz2
gentoo-2-622e4fea189441d1919471934ea567bee6c7fcfd.zip
Added a new revision with dmix patch to resolve bug #104487. Changing KEYWORDS from arch to ~arch on all stable architectures.
(Portage version: 1.589-cvs)
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/ChangeLog9
-rw-r--r--media-libs/openal/files/digest-openal-20050504-r21
-rw-r--r--media-libs/openal/files/openal-20050504-alsa_dmix.patch41
-rw-r--r--media-libs/openal/openal-20050504-r2.ebuild82
4 files changed, 132 insertions, 1 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index 46f8f4dc695a..dc1b2cc58cec 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/openal
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.42 2005/08/13 23:44:05 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.43 2005/09/02 14:35:22 wolf31o2 Exp $
+
+*openal-20050504-r2 (02 Sep 2005)
+
+ 02 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/openal-20050504-alsa_dmix.patch, +openal-20050504-r2.ebuild:
+ Added a new revision with dmix patch to resolve bug #104487. Changing
+ KEYWORDS from arch to ~arch on all stable architectures.
13 Aug 2005; Michael Hanselmann <hansmi@gentoo.org>
openal-20050504-r1.ebuild:
diff --git a/media-libs/openal/files/digest-openal-20050504-r2 b/media-libs/openal/files/digest-openal-20050504-r2
new file mode 100644
index 000000000000..fc84cbeaf891
--- /dev/null
+++ b/media-libs/openal/files/digest-openal-20050504-r2
@@ -0,0 +1 @@
+MD5 c2b74df0028d36d24745b4db9867de97 openal-20050504.tar.bz2 6284126
diff --git a/media-libs/openal/files/openal-20050504-alsa_dmix.patch b/media-libs/openal/files/openal-20050504-alsa_dmix.patch
new file mode 100644
index 000000000000..2cd6f569d74d
--- /dev/null
+++ b/media-libs/openal/files/openal-20050504-alsa_dmix.patch
@@ -0,0 +1,41 @@
+--- ./openal-20050504/linux/src/arch/alsa/alsa.c 2005-03-25 11:48:23.000000000 +0100
++++ ./openal-modified/linux/src/arch/alsa/alsa.c 2005-09-01 16:31:45.000000000 +0200
+@@ -58,6 +58,7 @@
+ static int (*psnd_pcm_hw_params_set_channels)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, unsigned int val) = NULL;
+ static int (*psnd_pcm_hw_params_set_format)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, snd_pcm_format_t val) = NULL;
+ static int (*psnd_pcm_hw_params_set_periods)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, unsigned int val, int dir) = NULL;
++static int (*psnd_pcm_hw_params_set_periods_near)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, unsigned int *val, int *dir) = NULL;
+ static int (*psnd_pcm_hw_params_set_rate)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, unsigned int val, int dir) = NULL;
+ static int (*psnd_pcm_hw_params_set_rate_near)(snd_pcm_t *pcm, snd_pcm_hw_params_t *params, unsigned int *val, int *dir) = NULL;
+ static size_t (*psnd_pcm_hw_params_sizeof)(void) = NULL;
+@@ -143,6 +144,7 @@
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_format);
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_period_size);
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_periods);
++ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_periods_near);
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_rate);
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_set_rate_near);
+ OPENAL_LOAD_ALSA_SYMBOL(snd_pcm_hw_params_sizeof);
+@@ -450,7 +452,7 @@
+ return AL_FALSE;
+ }
+
+- err = psnd_pcm_hw_params_set_periods(phandle, setup, ai->periods, 0);
++ err = psnd_pcm_hw_params_set_periods_near(phandle, setup, &ai->periods, 0);
+ if (err < 0) {
+ _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
+ "set_read_alsa: %s\n", psnd_strerror(err));
+@@ -622,7 +624,7 @@
+
+
+ /* Set number of periods. Periods used to be called fragments. */
+- err = psnd_pcm_hw_params_set_periods(phandle, setup, ai->periods, 0);
++ err = psnd_pcm_hw_params_set_periods_near(phandle, setup, &ai->periods, 0);
+ if (err < 0) {
+ _alDebug(ALD_MAXIMUS, __FILE__, __LINE__,
+ "set_write_alsa: %s\n", psnd_strerror(err));
+@@ -812,4 +814,3 @@
+
+ return(retval*chans);
+ }
+-
diff --git a/media-libs/openal/openal-20050504-r2.ebuild b/media-libs/openal/openal-20050504-r2.ebuild
new file mode 100644
index 000000000000..b8f61638fd0b
--- /dev/null
+++ b/media-libs/openal/openal-20050504-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-20050504-r2.ebuild,v 1.1 2005/09/02 14:35:22 wolf31o2 Exp $
+
+inherit eutils gnuconfig
+
+IUSE="alsa arts esd sdl debug oggvorbis mpeg"
+DESCRIPTION="OpenAL, the Open Audio Library, is an open, vendor-neutral, cross-platform API for interactive, primarily spatialized audio"
+SRC_URI="http://dev.gentoo.org/~eradicator/openal/${P}.tar.bz2"
+HOMEPAGE="http://www.openal.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0.2 )
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ sdl? ( media-libs/libsdl )
+ oggvorbis? ( media-libs/libvorbis )
+ mpeg? ( media-libs/smpeg )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+
+S="${S}/linux"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use alsa && epatch ${FILESDIR}/${P}-alsa_capture.patch && \
+ epatch ${FILESDIR}/${P}-alsa_dmix.patch
+ epatch ${FILESDIR}/${P}-destdir.patch
+
+ gnuconfig_update
+
+ export WANT_AUTOCONF=2.5
+ autoheader || die
+ autoconf || die
+}
+
+src_compile() {
+ local myconf
+
+ use esd && myconf="${myconf} --enable-esd"
+ use sdl && myconf="${myconf} --enable-sdl"
+ use alsa && myconf="${myconf} --enable-alsa"
+ use arts && myconf="${myconf} --enable-arts"
+ use mpeg && myconf="${myconf} --enable-smpeg"
+ use oggvorbis && myconf="${myconf} --enable-vorbis"
+ use debug && myconf="${myconf} --enable-debug-maximus"
+
+ econf ${myconf} --enable-paranoid-locks --libdir=/usr/$(get_libdir) \
+ --enable-capture --enable-optimize || die
+ emake all || die
+}
+
+src_install() {
+ cd ${S}/linux
+
+ make install DESTDIR="${D}" || die
+
+ dodoc CREDITS ChangeLog INSTALL NOTES PLATFORM TODO
+ dodoc ${FILESDIR}/openalrc
+ makeinfo doc/openal.texi
+ doinfo doc/openal.info
+
+ cd ${S}
+ dodoc CHANGES COPYING CREDITS
+ dohtml docs/*.html
+}
+
+pkg_postinst() {
+ einfo "There is a sample openalrc file in /usr/share/doc/${P} which"
+ einfo "sets up 4 speaker surround sound with ALSA. Simply copy it to your:"
+ einfo " ~/.openalrc"
+ einfo "to use it."
+}