summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-03-26 16:07:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-03-26 16:07:02 +0000
commitc21dd06b2cc618f802c9c03b81e3893e4eb6101e (patch)
treec73732613c8791b37954a41981d62429e0637871 /media-libs/phonon/phonon-9999.ebuild
parentDepend on virtual/ffmpeg instead of media-video/ffmpeg. (diff)
downloadgentoo-2-c21dd06b2cc618f802c9c03b81e3893e4eb6101e.tar.gz
gentoo-2-c21dd06b2cc618f802c9c03b81e3893e4eb6101e.tar.bz2
gentoo-2-c21dd06b2cc618f802c9c03b81e3893e4eb6101e.zip
Moved phonon to new category media-libs
(Portage version: 2.1.9.44/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-libs/phonon/phonon-9999.ebuild')
-rw-r--r--media-libs/phonon/phonon-9999.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/phonon/phonon-9999.ebuild b/media-libs/phonon/phonon-9999.ebuild
new file mode 100644
index 000000000000..b4476485ab55
--- /dev/null
+++ b/media-libs/phonon/phonon-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/phonon/phonon-9999.ebuild,v 1.1 2011/03/26 16:07:01 dilfridge Exp $
+
+EAPI="3"
+
+inherit cmake-utils git
+
+DESCRIPTION="KDE multimedia API"
+HOMEPAGE="https://projects.kde.org/projects/kdesupport/phonon"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}"
+
+LICENSE="LGPL-2.1"
+KEYWORDS=""
+SLOT="0"
+IUSE="debug gstreamer pulseaudio +vlc xine"
+
+COMMON_DEPEND="
+ >=x11-libs/qt-core-4.6.0:4
+ >=x11-libs/qt-dbus-4.6.0:4
+ >=x11-libs/qt-gui-4.6.0:4
+ >=x11-libs/qt-test-4.6.0:4
+ pulseaudio? (
+ dev-libs/glib:2
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+# directshow? ( media-sound/phonon-directshow )
+# mmf? ( media-sound/phonon-mmf )
+# mplayer? ( media-sound/phonon-mplayer )
+# quicktime? ( media-sound/phonon-quicktime )
+# waveout? ( media-sound/phonon-waveout )
+PDEPEND="
+ gstreamer? ( media-sound/phonon-gstreamer )
+ vlc? ( >=media-sound/phonon-vlc-0.3.2 )
+ xine? ( >=media-sound/phonon-xine-0.4.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-base/phonon-xine
+ !x11-libs/qt-phonon:4
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/automoc-0.9.87
+ dev-util/pkgconfig
+"
+
+pkg_setup() {
+ if use !gstreamer && use !vlc && use !xine; then
+ ewarn "You must at least select one backend for phonon to be usuable"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pulseaudio GLIB2)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+ cmake-utils_src_configure
+}