summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-12-04 23:42:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-12-04 23:42:23 +0000
commit4ec1b84b7f653dae4c55ac08cb3f2d46f23f3e85 (patch)
tree61be651f21ba118dedf454167f79aca7ddbb3b8b /media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild
parentmigrate-run service was dropped, so we can remove it from the ebuild. (diff)
downloadgentoo-2-4ec1b84b7f653dae4c55ac08cb3f2d46f23f3e85.tar.gz
gentoo-2-4ec1b84b7f653dae4c55ac08cb3f2d46f23f3e85.tar.bz2
gentoo-2-4ec1b84b7f653dae4c55ac08cb3f2d46f23f3e85.zip
version bump
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild')
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild
new file mode 100644
index 000000000000..d1f15b115b2f
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/sdl-gfx-2.0.23.ebuild,v 1.1 2011/12/04 23:42:23 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools multilib
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc mmx static-libs"
+
+DEPEND="media-libs/libsdl[video]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e 's/-O //' configure.in || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable mmx) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml -r Docs/*
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib*.la
+}