summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-10-29 23:01:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-10-29 23:01:41 +0000
commit9485a35cc0fb8313444485237f68ea79323b19da (patch)
treee1630706e098f4d31acfa046fb43460764c858ed /media-libs/sdl-gfx
parentFix my total breakage (diff)
downloadgentoo-2-9485a35cc0fb8313444485237f68ea79323b19da.tar.gz
gentoo-2-9485a35cc0fb8313444485237f68ea79323b19da.tar.bz2
gentoo-2-9485a35cc0fb8313444485237f68ea79323b19da.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sdl-gfx')
-rw-r--r--media-libs/sdl-gfx/ChangeLog7
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.24.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-libs/sdl-gfx/ChangeLog b/media-libs/sdl-gfx/ChangeLog
index 0a574c010f0c..b4d6a665bbf9 100644
--- a/media-libs/sdl-gfx/ChangeLog
+++ b/media-libs/sdl-gfx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-gfx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/ChangeLog,v 1.87 2012/05/17 15:22:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/ChangeLog,v 1.88 2012/10/29 23:01:41 mr_bones_ Exp $
+
+*sdl-gfx-2.0.24 (29 Oct 2012)
+
+ 29 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org> +sdl-gfx-2.0.24.ebuild:
+ version bump
17 May 2012; Alexis Ballier <aballier@gentoo.org> sdl-gfx-2.0.23.ebuild:
keyword ~amd64-fbsd
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.24.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.24.ebuild
new file mode 100644
index 000000000000..64f6d3e4a060
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.24.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-gfx/sdl-gfx-2.0.24.ebuild,v 1.1 2012/10/29 23:01:41 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc mmx static-libs"
+
+DEPEND="media-libs/libsdl[video]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e 's/-O //' configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable mmx) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml -r Docs/*
+ prune_libtool_files
+}