summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-02-18 18:07:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-02-18 18:07:19 +0000
commit5acd91cc05b6c2d6b05dcc482fc0aebdafb2643b (patch)
tree6f13ab978aef47aff866d7a23ea2717c7818aa2a /media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild
parentRespect CFLAGS, LDFLAGS, CC. (diff)
downloadgentoo-2-5acd91cc05b6c2d6b05dcc482fc0aebdafb2643b.tar.gz
gentoo-2-5acd91cc05b6c2d6b05dcc482fc0aebdafb2643b.tar.bz2
gentoo-2-5acd91cc05b6c2d6b05dcc482fc0aebdafb2643b.zip
Ugly hack for bug #305403
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild')
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild
new file mode 100644
index 000000000000..5b510d2e4ee3
--- /dev/null
+++ b/media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.10-r1.ebuild,v 1.1 2010/02/18 18:07:19 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="gif jpeg tiff png"
+
+DEPEND="sys-libs/zlib
+ media-libs/libsdl
+ png? ( media-libs/libpng )
+ jpeg? ( >=media-libs/jpeg-7:0 )
+ tiff? ( media-libs/tiff )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e 's/sort/sort -r/' \
+ configure.in \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ --enable-bmp \
+ --enable-lbm \
+ --enable-pcx \
+ --enable-pnm \
+ --enable-tga \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dobin .libs/showimage || die "dobin failed"
+ dodoc CHANGES README
+}