summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 17:11:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 17:11:52 +0000
commited6b2421cec5daf3466352ba648169bf565620c6 (patch)
treef449a9d6a2231d3fbb5cdfb1d44be864e9a53d8c /media-libs/sdl-mixer
parentremoved unneeded path install for /usr/local/share; fix i18n install bug, sta... (diff)
downloadgentoo-2-ed6b2421cec5daf3466352ba648169bf565620c6.tar.gz
gentoo-2-ed6b2421cec5daf3466352ba648169bf565620c6.tar.bz2
gentoo-2-ed6b2421cec5daf3466352ba648169bf565620c6.zip
Formalize the USE flag setting with REQUIRED_USE (bug #412407)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/ChangeLog8
-rw-r--r--media-libs/sdl-mixer/metadata.xml6
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.12-r1.ebuild101
3 files changed, 112 insertions, 3 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index 1b404285924c..31aff8baca0b 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/sdl-mixer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.97 2012/04/17 21:47:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.98 2012/04/18 17:11:52 mr_bones_ Exp $
+
+*sdl-mixer-1.2.12-r1 (18 Apr 2012)
+
+ 18 Apr 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +sdl-mixer-1.2.12-r1.ebuild, metadata.xml:
+ Formalize the USE flag setting with REQUIRED_USE (bug #412407)
17 Apr 2012; Brent Baude <ranger@gentoo.org> sdl-mixer-1.2.12.ebuild:
Marking sdl-mixer-1.2.12 ppc64 for bug 411531
diff --git a/media-libs/sdl-mixer/metadata.xml b/media-libs/sdl-mixer/metadata.xml
index 38f4fb4843ad..f6db1ba16a50 100644
--- a/media-libs/sdl-mixer/metadata.xml
+++ b/media-libs/sdl-mixer/metadata.xml
@@ -3,9 +3,11 @@
<pkgmetadata>
<herd>games</herd>
<use>
- <flag name='midi'>basic support for MIDI files</flag>
<flag name='fluidsynth'>Use <pkg>media-sound/fluidsynth</pkg> for MIDI support</flag>
- <flag name='wav'>support WAVE files</flag>
+ <flag name='midi'>basic support for MIDI files</flag>
+ <flag name='mod'>basic support for MOD files</flag>
<flag name='playtools'>Install playwave and playmus tools (useful for testing)</flag>
+ <flag name='smpeg'>Use <pkg>media-libs/smpeg</pkg> for MP3 support</flag>
+ <flag name='wav'>support WAVE files</flag>
</use>
</pkgmetadata>
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.12-r1.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r1.ebuild
new file mode 100644
index 000000000000..ffff9ae2b560
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.12-r1.ebuild,v 1.1 2012/04/18 17:11:52 mr_bones_ Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P=${P/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity vorbis +wav"
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mp3? ( || ( smpeg mad ) )
+ smpeg? ( mp3 )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+ "
+
+DEPEND=">=media-libs/libsdl-1.2.10
+ flac? ( media-libs/flac )
+ midi? (
+ fluidsynth? ( media-sound/fluidsynth )
+ timidity? ( media-sound/timidity++ )
+ )
+ mp3? (
+ mad? ( media-libs/libmad )
+ smpeg? ( >=media-libs/smpeg-0.4.4-r1 )
+ )
+ mod? (
+ modplug? ( media-libs/libmodplug )
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 media-libs/libogg )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wav.patch
+ sed -i \
+ -e '/link.*play/s/-o/$(LDFLAGS) -o/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-music-flac-shared \
+ --disable-music-fluidsynth-shared \
+ --disable-music-mod-shared \
+ --disable-music-mp3-shared \
+ --disable-music-ogg-shared \
+ $(use_enable wav music-wave) \
+ $(use_enable vorbis music-ogg) \
+ $(use_enable mikmod music-mod) \
+ $(use_enable modplug music-mod-modplug) \
+ $(use_enable flac music-flac) \
+ $(use_enable static-libs static) \
+ $(use_enable smpeg music-mp3) \
+ $(use_enable mad music-mp3-mad-gpl) \
+ $(use_enable timidity music-timidity-midi) \
+ $(use_enable fluidsynth music-fluidsynth-midi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use playtools; then
+ emake DESTDIR="${D}" install-bin
+ fi
+ dodoc CHANGES README
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi ; then
+ if use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+ fi
+}