summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-17 21:37:25 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-17 21:37:25 +0000
commit79137114c4d1f51718aa8b1af35dfbdf29b10000 (patch)
tree824c9ee5569cdaadc93860c33286a0d2bb930284 /media-libs/sdl-sound
parentStable for HPPA (bug #206091). (diff)
downloadgentoo-2-79137114c4d1f51718aa8b1af35dfbdf29b10000.tar.gz
gentoo-2-79137114c4d1f51718aa8b1af35dfbdf29b10000.tar.bz2
gentoo-2-79137114c4d1f51718aa8b1af35dfbdf29b10000.zip
Version bump.
(Portage version: 2.2_pre5)
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/ChangeLog10
-rw-r--r--media-libs/sdl-sound/files/sdl-sound-1.0.2-headers.patch12
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.2.ebuild54
3 files changed, 74 insertions, 2 deletions
diff --git a/media-libs/sdl-sound/ChangeLog b/media-libs/sdl-sound/ChangeLog
index 68156a059b28..cdec253c3446 100644
--- a/media-libs/sdl-sound/ChangeLog
+++ b/media-libs/sdl-sound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/sdl-sound
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.32 2007/11/01 19:06:05 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.33 2008/04/17 21:37:24 vapier Exp $
+
+*sdl-sound-1.0.2 (17 Apr 2008)
+
+ 17 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/sdl-sound-1.0.2-headers.patch, +sdl-sound-1.0.2.ebuild:
+ Version bump.
01 Nov 2007; Raúl Porcel <armin76@gentoo.org> sdl-sound-1.0.1-r2.ebuild:
sparc stable, thanks to Alex Maclean for testing
diff --git a/media-libs/sdl-sound/files/sdl-sound-1.0.2-headers.patch b/media-libs/sdl-sound/files/sdl-sound-1.0.2-headers.patch
new file mode 100644
index 000000000000..c960692a93f9
--- /dev/null
+++ b/media-libs/sdl-sound/files/sdl-sound-1.0.2-headers.patch
@@ -0,0 +1,12 @@
+we use log() here, so need math.h
+
+--- decoders/shn.c (revision 553)
++++ decoders/shn.c (working copy)
+@@ -50,6 +50,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <math.h>
+
+ #include "SDL_sound.h"
+
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.2.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.2.ebuild
new file mode 100644
index 000000000000..61710d2f1fdf
--- /dev/null
+++ b/media-libs/sdl-sound/sdl-sound-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.2.ebuild,v 1.1 2008/04/17 21:37:24 vapier Exp $
+
+inherit eutils
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="A library that handles the decoding of sound file formats"
+HOMEPAGE="http://icculus.org/SDL_sound/"
+SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="flac mikmod vorbis speex physfs mp3 mpeg"
+
+RDEPEND=">=media-libs/libsdl-1.2
+ flac? ( media-libs/flac )
+ mikmod? ( >=media-libs/libmikmod-3.1.9 media-libs/libmodplug )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 )
+ speex? ( media-libs/speex media-libs/libogg )
+ physfs? ( dev-games/physfs )
+ mpeg? ( media-libs/smpeg )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-midi \
+ $(use_enable mpeg smpeg) \
+ $(use_enable mp3 mpglib) \
+ $(use_enable flac) \
+ $(use_enable speex) \
+ $(use_enable mikmod) \
+ $(use_enable mikmod modplug) \
+ $(use_enable physfs) \
+ $(use_enable vorbis ogg) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGELOG CREDITS README TODO
+}