summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-16 15:20:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-16 15:20:32 +0000
commitf538efff17e342029326b68236c0246fb33369b9 (patch)
tree57bbabdff69e085a76b55dea5e7800149db0124b /media-libs/stk
parentStable on alpha, bug #369409 (diff)
downloadgentoo-2-f538efff17e342029326b68236c0246fb33369b9.tar.gz
gentoo-2-f538efff17e342029326b68236c0246fb33369b9.tar.bz2
gentoo-2-f538efff17e342029326b68236c0246fb33369b9.zip
revbump for previous fix
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/stk')
-rw-r--r--media-libs/stk/ChangeLog7
-rw-r--r--media-libs/stk/stk-4.4.3-r1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/media-libs/stk/ChangeLog b/media-libs/stk/ChangeLog
index 3ba7fa4f46e7..ce9013899cfb 100644
--- a/media-libs/stk/ChangeLog
+++ b/media-libs/stk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/stk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/stk/ChangeLog,v 1.9 2012/01/15 15:34:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/stk/ChangeLog,v 1.10 2012/01/16 15:20:32 aballier Exp $
+
+*stk-4.4.3-r1 (16 Jan 2012)
+
+ 16 Jan 2012; Alexis Ballier <aballier@gentoo.org> +stk-4.4.3-r1.ebuild:
+ revbump for previous fix
15 Jan 2012; Alexis Ballier <aballier@gentoo.org>
+files/stk-4.4.3/040_all_sharedliblink.patch:
diff --git a/media-libs/stk/stk-4.4.3-r1.ebuild b/media-libs/stk/stk-4.4.3-r1.ebuild
new file mode 100644
index 000000000000..b9593f2d6f47
--- /dev/null
+++ b/media-libs/stk/stk-4.4.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/stk/stk-4.4.3-r1.ebuild,v 1.1 2012/01/16 15:20:32 aballier Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="Synthesis ToolKit in C++"
+HOMEPAGE="http://ccrma.stanford.edu/software/stk/"
+SRC_URI="http://ccrma.stanford.edu/software/stk/release/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug doc jack oss"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/perl"
+
+src_prepare() {
+ EPATCH_SUFFIX="patch" epatch "${FILESDIR}/${P}"
+ eautoreconf
+}
+
+src_configure() {
+ #breaks with --disable-foo...uses as --enable-foo
+ local myconf
+ if use debug; then
+ myconf="${myconf} --enable-debug"
+ fi
+ if use oss; then
+ myconf="${myconf} --with-oss"
+ fi
+ if use alsa; then
+ myconf="${myconf} --with-alsa"
+ fi
+ if use jack; then
+ myconf="${myconf} --with-jack"
+ fi
+
+ econf ${myconf} \
+ RAWWAVE_PATH=/usr/share/stk/rawwaves/
+}
+
+src_install() {
+ dodoc README || die "Failed to install README"
+ # install the lib
+ dolib src/libstk.* || die "Failed to install libstk.*"
+ # install headers
+ insinto /usr/include/stk || die "Failed to create header directory."
+ doins include/*.h include/*.msg include/*.tbl \
+ || die "Failed to install msg, tbl and h files."
+ # install rawwaves
+ insinto /usr/share/stk/rawwaves || die "Failed to create rawwave directory."
+ doins rawwaves/*.raw || die "Failed to install rawwave files."
+ # install docs
+ if use doc; then
+ dohtml -r doc/html/* || die "Failed to install docs."
+ fi
+}