summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-23 22:48:52 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-23 22:48:52 +0000
commit3e7eea4b0b55f0db1225abee2267fb45615a9746 (patch)
tree611786dc4f512d5e08a976d7775d12b62788e101 /media-libs/svgalib
parentStable on sparc. (Manifest recommit) (diff)
downloadgentoo-2-3e7eea4b0b55f0db1225abee2267fb45615a9746.tar.gz
gentoo-2-3e7eea4b0b55f0db1225abee2267fb45615a9746.tar.bz2
gentoo-2-3e7eea4b0b55f0db1225abee2267fb45615a9746.zip
Changed the detection method for 2.4 kernels in both of the compatibility patches; closes bug #42307.
Diffstat (limited to 'media-libs/svgalib')
-rw-r--r--media-libs/svgalib/ChangeLog7
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.17-linux2.6.patch11
-rw-r--r--media-libs/svgalib/files/svgalib-1.9.18-linux2.6.patch11
3 files changed, 9 insertions, 20 deletions
diff --git a/media-libs/svgalib/ChangeLog b/media-libs/svgalib/ChangeLog
index 912d373fa8e4..6dc546cb8741 100644
--- a/media-libs/svgalib/ChangeLog
+++ b/media-libs/svgalib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/svgalib
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.30 2004/02/23 21:51:12 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/svgalib/ChangeLog,v 1.31 2004/02/23 22:48:51 plasmaroo Exp $
+
+ 23 Feb 2004; <plasmaroo@gentoo.org> files/svgalib-1.9.17-linux2.6.patch,
+ files/svgalib-1.9.18-linux2.6.patch:
+ Changed the detection method for 2.4 kernels in both of the compatibility
+ patches; closes bug #42307.
23 Feb 2004; Martin Schlemmer <azarah@gentoo.org>
files/svgalib-1.9.18-linux2.6.patch:
diff --git a/media-libs/svgalib/files/svgalib-1.9.17-linux2.6.patch b/media-libs/svgalib/files/svgalib-1.9.17-linux2.6.patch
index c9bbf837bf86..d62ebf274ab3 100644
--- a/media-libs/svgalib/files/svgalib-1.9.17-linux2.6.patch
+++ b/media-libs/svgalib/files/svgalib-1.9.17-linux2.6.patch
@@ -121,18 +121,11 @@ diff -urpwN svgalib-1.9.17/kernel/svgalib_helper/kernel25compat.h svgalib-1.9.17
diff -urpwN svgalib-1.9.17/kernel/svgalib_helper/kernel26compat.h svgalib-1.9.17.kernel2.6/kernel/svgalib_helper/kernel26compat.h
--- svgalib-1.9.17/kernel/svgalib_helper/kernel26compat.h 1970-01-01 02:00:00.000000000 +0200
+++ svgalib-1.9.17.kernel2.6/kernel/svgalib_helper/kernel26compat.h 2003-08-03 14:33:28.000000000 +0200
-@@ -0,0 +1,49 @@
+@@ -0,0 +1,42 @@
+#ifndef minor
+#define minor(x) MINOR(x)
+#endif
+
-+#ifndef KERNEL_VERSION
-+# include <linux/version.h>
-+#else
-+# undef KERNEL_VERSION
-+# include <linux/version.h>
-+#endif
-+
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
+
+# ifdef KERNEL_2_6
@@ -140,7 +133,7 @@ diff -urpwN svgalib-1.9.17/kernel/svgalib_helper/kernel26compat.h svgalib-1.9.17
+# endif
+
+#define my_remap_page_range(vma, start, ofs, len, prot) remap_page_range(start,ofs,len,prot)
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,4,23)
++# ifndef IRQ_NONE
+ typedef void irqreturn_t;
+# endif
+#else
diff --git a/media-libs/svgalib/files/svgalib-1.9.18-linux2.6.patch b/media-libs/svgalib/files/svgalib-1.9.18-linux2.6.patch
index c1b489473499..335d6409630d 100644
--- a/media-libs/svgalib/files/svgalib-1.9.18-linux2.6.patch
+++ b/media-libs/svgalib/files/svgalib-1.9.18-linux2.6.patch
@@ -44,20 +44,11 @@ diff -urpN svgalib-1.9.18/kernel/svgalib_helper/Makefile svgalib-1.9.18.new/kern
diff -urpN svgalib-1.9.18/kernel/svgalib_helper/kernel26compat.h svgalib-1.9.18.new/kernel/svgalib_helper/kernel26compat.h
--- svgalib-1.9.18/kernel/svgalib_helper/kernel26compat.h 2003-10-04 15:42:01.000000000 +0200
+++ svgalib-1.9.18.new/kernel/svgalib_helper/kernel26compat.h 2004-02-23 00:41:03.176196576 +0200
-@@ -1,5 +1,8 @@
- #ifndef KERNEL_VERSION
- # include <linux/version.h>
-+#else
-+# undef KERNEL_VERSION
-+# include <linux/version.h>
- #endif
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
-
@@ -9,9 +12,11 @@
# define my_io_remap_page_range(vma, start, ofs, len, prot) io_remap_page_range(start,ofs,len,prot)
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(2,4,23)
++# ifndef IRQ_NONE
typedef void irqreturn_t;
-# define IRQ_NONE
-# define IRQ_HANDLED