summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-29 16:33:58 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-29 16:33:58 +0000
commitb437262429bf3ee7f51483549798f6b6225fb05b (patch)
treece3e1741ce8df0fbbed98faa77acdd02899962da /media-libs/vigra
parentAdd slot operator to hdf5 dependency (diff)
downloadgentoo-2-b437262429bf3ee7f51483549798f6b6225fb05b.tar.gz
gentoo-2-b437262429bf3ee7f51483549798f6b6225fb05b.tar.bz2
gentoo-2-b437262429bf3ee7f51483549798f6b6225fb05b.zip
Drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/ChangeLog6
-rw-r--r--media-libs/vigra/vigra-1.8.0-r1.ebuild112
-rw-r--r--media-libs/vigra/vigra-1.8.0.ebuild121
3 files changed, 5 insertions, 234 deletions
diff --git a/media-libs/vigra/ChangeLog b/media-libs/vigra/ChangeLog
index 589e0ea575b5..ed5adff753b7 100644
--- a/media-libs/vigra/ChangeLog
+++ b/media-libs/vigra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/vigra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.68 2014/12/29 16:32:04 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/ChangeLog,v 1.69 2014/12/29 16:33:58 dilfridge Exp $
+
+ 29 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org> -vigra-1.8.0.ebuild,
+ -vigra-1.8.0-r1.ebuild:
+ Drop old
29 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org> vigra-1.8.0.ebuild,
vigra-1.8.0-r1.ebuild, vigra-1.9.0.ebuild, vigra-1.10.0.ebuild:
diff --git a/media-libs/vigra/vigra-1.8.0-r1.ebuild b/media-libs/vigra/vigra-1.8.0-r1.ebuild
deleted file mode 100644
index 3b6bc61e0284..000000000000
--- a/media-libs/vigra/vigra-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.8.0-r1.ebuild,v 1.3 2014/12/29 16:32:04 dilfridge Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads,xml"
-
-# This ebuild could use python-r1 in the future when upstream gets Python 3.x
-# support working
-inherit cmake-utils eutils multilib python-single-r1
-
-MY_P=${P}-src
-
-DESCRIPTION="C++ computer vision library with emphasize on customizable algorithms and data structures"
-HOMEPAGE="http://hci.iwr.uni-heidelberg.de/vigra/"
-SRC_URI="http://hci.iwr.uni-heidelberg.de/vigra/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +fftw +hdf5 +jpeg openexr +png +python test +tiff"
-
-# Pull in dev-lang/python:2.7 for vigra-config which is always installed
-RDEPEND="dev-lang/python:2.7
- >=dev-libs/boost-1.52.0-r6[python?,${PYTHON_USEDEP}]
- fftw? ( sci-libs/fftw:3.0 )
- hdf5? ( sci-libs/hdf5:= )
- jpeg? ( virtual/jpeg )
- openexr? ( media-libs/openexr:= )
- png? ( media-libs/libpng:0= )
- python? ( ${PYTHON_DEPS} )
- tiff? ( media-libs/tiff:0= )"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- python? ( >=dev-python/sphinx-1.1.3-r5[${PYTHON_USEDEP}] )
- )
- test? (
- python? ( >=dev-python/nose-1.1.2-r1[${PYTHON_USEDEP}] )
- )"
-REQUIRED_USE="doc? ( hdf5 fftw )
- python? ( hdf5 )
- test? ( hdf5 python fftw )"
-
-CMAKE_IN_SOURCE_BUILD=1
-
-DOCS=( README.txt )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-automagicness.patch \
- "${FILESDIR}"/${P}-numpy_doc.patch \
- "${FILESDIR}"/${P}-gcc47.patch \
- "${FILESDIR}"/${P}-doxygen.patch
-
- # Don't build nor install API docs when not requested
- use doc || { sed -i -e '/ADD_SUBDIRECTORY(docsrc)/d' CMakeLists.txt || die; }
-
- # Don't use python_fix_shebang because we can't put this behind USE="python"
- sed -i -e '/env/s:python:python2:' config/vigra-config.in || die
-}
-
-src_configure() {
- local libdir=$(get_libdir)
-
- # required for ddocdir
- _check_build_dir init
- # vigranumpy needs python and if enabled it ooms
- # doc needs doxygen and python
- # walgrind no use for us since we restrict test
- # $(cmake-utils_use_with valgrind VALGRIND)
- local mycmakeargs=(
- -DDOCDIR="${CMAKE_BUILD_DIR}"/doc
- -DLIBDIR_SUFFIX=${libdir/lib}
- -DDOCINSTALL=share/doc/${PF}
- -DWITH_VALGRIND=OFF
- $(cmake-utils_use_with python VIGRANUMPY)
- $(cmake-utils_use_with png)
- $(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with openexr)
- $(cmake-utils_use_with tiff)
- $(cmake-utils_use_with fftw FFTW3)
- $(cmake-utils_use_with hdf5)
- $(cmake-utils_use_build test TESTING)
- $(cmake-utils_use test CREATE_CTEST_TARGETS)
- $(cmake-utils_use test AUTOBUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doc
-}
-
-src_test() { :; } #390447
-
-src_install() {
- cmake-utils_src_install
-
- use python && python_optimize
-
- # drop useless cmake files from libdir
- rm -rf "${ED}"/usr/$(get_libdir)/${PN}
-}
diff --git a/media-libs/vigra/vigra-1.8.0.ebuild b/media-libs/vigra/vigra-1.8.0.ebuild
deleted file mode 100644
index fa15a53f1245..000000000000
--- a/media-libs/vigra/vigra-1.8.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vigra/vigra-1.8.0.ebuild,v 1.5 2014/12/29 16:32:04 dilfridge Exp $
-
-EAPI=5
-
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH_OPT="python"
-PYTHON_USE_WITH="threads xml"
-
-MY_P=${P}-src
-
-inherit base cmake-utils multilib python
-
-DESCRIPTION="C++ computer vision library with emphasize on customizable algorithms and data structures"
-HOMEPAGE="http://hci.iwr.uni-heidelberg.de/vigra/"
-SRC_URI="http://hci.iwr.uni-heidelberg.de/vigra/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc +fftw +hdf5 +jpeg openexr +png +python test +tiff"
-
-RDEPEND="
- >=dev-libs/boost-1.40[python?]
- fftw? ( sci-libs/fftw:3.0 )
- hdf5? ( sci-libs/hdf5:= )
- jpeg? ( virtual/jpeg )
- openexr? ( media-libs/openexr:= )
- png? ( media-libs/libpng:0= )
- tiff? ( media-libs/tiff:0= )
-"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- python? ( dev-python/sphinx )
- )
- test? (
- python? ( dev-python/nose )
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-automagicness.patch"
- "${FILESDIR}/${P}-numpy_doc.patch"
- "${FILESDIR}/${P}-gcc47.patch"
-)
-
-REQUIRED_USE="
- doc? ( hdf5 fftw )
- python? ( hdf5 )
- test? ( hdf5 python fftw )
-"
-
-CMAKE_IN_SOURCE_BUILD=1
-
-DOCS=(README.txt)
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- base_src_prepare
-
- # Don't build nor install API docs when not requested
- use doc || sed -e '/ADD_SUBDIRECTORY(docsrc)/d' -i CMakeLists.txt || die
-}
-
-src_configure() {
- local libdir=$(get_libdir)
-
- # required for ddocdir
- _check_build_dir init
- # vigranumpy needs python and if enabled it ooms
- # doc needs doxygen and python
- # walgrind no use for us since we restrict test
- # $(cmake-utils_use_with valgrind VALGRIND)
- local mycmakeargs=(
- "-DDOCDIR=${CMAKE_BUILD_DIR}/doc"
- "-DLIBDIR_SUFFIX=${libdir/lib}"
- "-DDOCINSTALL=share/doc/${PF}"
- "-DWITH_VALGRIND=OFF"
- $(cmake-utils_use_with python VIGRANUMPY)
- $(cmake-utils_use_with png)
- $(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with openexr)
- $(cmake-utils_use_with tiff)
- $(cmake-utils_use_with fftw FFTW3)
- $(cmake-utils_use_with hdf5)
- $(cmake-utils_use_build test TESTING)
- $(cmake-utils_use test CREATE_CTEST_TARGETS)
- $(cmake-utils_use test AUTOBUILD_TESTS)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doc
-}
-
-src_install() {
- cmake-utils_src_install
-
- # drop useless cmake files from libdir
- rm -rf "${ED}"/usr/$(get_libdir)/${PN}/
-}
-
-src_test() { : ; }
-# bug 390447
-
-pkg_postinst() {
- use python && python_mod_optimize vigra
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup vigra
-}