summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-10 15:58:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-10 15:58:15 +0000
commit0c20c0e525152246ad908cd0158dd0545aea31d3 (patch)
tree8c0252c16e7eb45116d6c31029c9044e5f12f5db /media-libs/vo-aacenc
parentversion bump (diff)
downloadgentoo-2-0c20c0e525152246ad908cd0158dd0545aea31d3.tar.gz
gentoo-2-0c20c0e525152246ad908cd0158dd0545aea31d3.tar.bz2
gentoo-2-0c20c0e525152246ad908cd0158dd0545aea31d3.zip
version bump
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/vo-aacenc')
-rw-r--r--media-libs/vo-aacenc/ChangeLog7
-rw-r--r--media-libs/vo-aacenc/vo-aacenc-0.1.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-libs/vo-aacenc/ChangeLog b/media-libs/vo-aacenc/ChangeLog
index 1c8adde11804..41265251d360 100644
--- a/media-libs/vo-aacenc/ChangeLog
+++ b/media-libs/vo-aacenc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/vo-aacenc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/ChangeLog,v 1.2 2011/05/03 22:22:10 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/ChangeLog,v 1.3 2011/05/10 15:58:15 aballier Exp $
+
+*vo-aacenc-0.1.1 (10 May 2011)
+
+ 10 May 2011; Alexis Ballier <aballier@gentoo.org> +vo-aacenc-0.1.1.ebuild:
+ version bump
03 May 2011; Luca Barbato <lu_zero@gentoo.org> vo-aacenc-9999.ebuild:
Update to git-2
diff --git a/media-libs/vo-aacenc/vo-aacenc-0.1.1.ebuild b/media-libs/vo-aacenc/vo-aacenc-0.1.1.ebuild
new file mode 100644
index 000000000000..8347c269ec37
--- /dev/null
+++ b/media-libs/vo-aacenc/vo-aacenc-0.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/vo-aacenc/vo-aacenc-0.1.1.ebuild,v 1.1 2011/05/10 15:58:15 aballier Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/mstorsjo/${PN}.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
+fi
+
+inherit eutils multilib autotools ${SCM}
+
+DESCRIPTION="VisualOn AAC encoder library"
+HOMEPAGE="http://sourceforge.net/projects/opencore-amr/"
+
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Official release
+ SRC_URI="mirror://sourceforge/opencore-amr/${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+[[ ${PV} == *9999 ]] || KEYWORDS="~amd64 ~arm ~x86-fbsd ~x64-macos"
+IUSE="examples static-libs neon"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable examples example) \
+ $(use_enable neon armv7neon) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}"usr/$(get_libdir) -name '*.la' -delete
+}