summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-04 21:49:21 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-04 21:49:21 +0000
commite30ad67848cafba95e54603bd886a7dbe10f75ed (patch)
treefa4e7f2f3daefdad9140ea178a4b97aecc9b5041 /media-libs/win32codecs/win32codecs-20050216.ebuild
parentfix deps for bug #90894; tidy (diff)
downloadgentoo-2-e30ad67848cafba95e54603bd886a7dbe10f75ed.tar.gz
gentoo-2-e30ad67848cafba95e54603bd886a7dbe10f75ed.tar.bz2
gentoo-2-e30ad67848cafba95e54603bd886a7dbe10f75ed.zip
the other way around
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-libs/win32codecs/win32codecs-20050216.ebuild')
-rw-r--r--media-libs/win32codecs/win32codecs-20050216.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/win32codecs/win32codecs-20050216.ebuild b/media-libs/win32codecs/win32codecs-20050216.ebuild
new file mode 100644
index 000000000000..27b850e8d3e5
--- /dev/null
+++ b/media-libs/win32codecs/win32codecs-20050216.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/win32codecs/win32codecs-20050216.ebuild,v 1.5 2005/05/04 21:49:21 luckyduck Exp $
+
+
+DESCRIPTION="Win32 binary codecs for video and audio playback support"
+SRC_URI="http://www1.mplayerhq.hu/MPlayer/releases/codecs/all-${PV}.tar.bz2"
+HOMEPAGE="http://www.mplayerhq.hu/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="quicktime real"
+
+S=${WORKDIR}/all-${PV}
+
+src_install() {
+ cd ${S}
+
+ # see #83221
+ insopts -m0644
+ dodir /usr/lib/win32
+
+ if use real
+ then
+ dodir /usr/lib/real
+ insinto /usr/lib/real
+ doins *so.6.0
+
+ # copy newly introduced codecs from realplayer10
+ # see the ChangeLog online
+ doins *.so
+
+ # fix bug #80321
+ ln -s ${D}/usr/lib/real/* ${D}/usr/lib/win32/
+ fi
+
+ insinto /usr/lib/win32
+ if use quicktime
+ then
+ doins *.qtx *.qts qtmlClient.dll
+ fi
+
+ doins *.dll *.ax *.xa *.acm *.vwp *.drv *.DLL
+
+ dodoc README
+}