summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-02-07 09:51:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-02-07 09:51:25 +0000
commita7a5188cf349fbab5268317e0be7647063a5db76 (patch)
tree5688c1cddf5ad82d6a8103f81530210ddeb2b211 /media-libs/wxsvg
parentVersion bump (diff)
downloadgentoo-2-a7a5188cf349fbab5268317e0be7647063a5db76.tar.gz
gentoo-2-a7a5188cf349fbab5268317e0be7647063a5db76.tar.bz2
gentoo-2-a7a5188cf349fbab5268317e0be7647063a5db76.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/wxsvg')
-rw-r--r--media-libs/wxsvg/ChangeLog10
-rw-r--r--media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch41
-rw-r--r--media-libs/wxsvg/wxsvg-1.0.2.ebuild37
3 files changed, 45 insertions, 43 deletions
diff --git a/media-libs/wxsvg/ChangeLog b/media-libs/wxsvg/ChangeLog
index 5e5cbddf3b51..083af797b3ba 100644
--- a/media-libs/wxsvg/ChangeLog
+++ b/media-libs/wxsvg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/wxsvg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.12 2009/10/21 02:27:12 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/ChangeLog,v 1.13 2010/02/07 09:51:24 dirtyepic Exp $
+
+*wxsvg-1.0.2 (07 Feb 2010)
+
+ 07 Feb 2010; Ryan Hill <dirtyepic@gentoo.org>
+ -files/wxsvg-1.0_beta7-freetype.patch, +wxsvg-1.0.2.ebuild:
+ Version bump.
21 Oct 2009; Ryan Hill <dirtyepic@gentoo.org> wxsvg-1.0.ebuild:
Fix EAPI 2 dependency.
diff --git a/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch b/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch
deleted file mode 100644
index cfc7acddb499..000000000000
--- a/media-libs/wxsvg/files/wxsvg-1.0_beta7-freetype.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -Naur wxsvg-1.0b7-orig/src/freetype/SVGCanvasTextFreetype.cpp wxsvg-1.0b7/src/freetype/SVGCanvasTextFreetype.cpp
---- wxsvg-1.0b7-orig/src/freetype/SVGCanvasTextFreetype.cpp 2007-04-22 21:08:31.000000000 -0600
-+++ wxsvg-1.0b7/src/freetype/SVGCanvasTextFreetype.cpp 2007-04-22 21:14:32.000000000 -0600
-@@ -163,7 +163,7 @@
- }
- }
-
--static gint moveto(FT_Vector* to, gpointer data)
-+static gint moveto(const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
-
-@@ -179,7 +179,7 @@
- return 0;
- }
-
--static gint lineto (FT_Vector* to, gpointer data)
-+static gint lineto (const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
-@@ -192,7 +192,7 @@
- return 0;
- }
-
--static gint conicto(FT_Vector* ftcontrol, FT_Vector* to, gpointer data)
-+static gint conicto(const FT_Vector* ftcontrol, const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
-@@ -207,8 +207,8 @@
- return 0;
- }
-
--static gint cubicto(FT_Vector* ftcontrol1, FT_Vector* ftcontrol2,
-- FT_Vector* to, gpointer data)
-+static gint cubicto(const FT_Vector* ftcontrol1, const FT_Vector* ftcontrol2,
-+ const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
diff --git a/media-libs/wxsvg/wxsvg-1.0.2.ebuild b/media-libs/wxsvg/wxsvg-1.0.2.ebuild
new file mode 100644
index 000000000000..0685022a10df
--- /dev/null
+++ b/media-libs/wxsvg/wxsvg-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/wxsvg/wxsvg-1.0.2.ebuild,v 1.1 2010/02/07 09:51:24 dirtyepic Exp $
+
+EAPI=2
+WX_GTK_VER="2.8"
+
+inherit wxwidgets
+
+MY_P=${P}_1
+
+DESCRIPTION="C++ library to create, manipulate and render SVG files."
+HOMEPAGE="http://wxsvg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="wxWinLL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="x11-libs/wxGTK:2.8[X]
+ >=dev-libs/glib-2.12
+ >=dev-libs/libxml2-2.6.26
+ >=media-libs/fontconfig-2.4
+ >=media-libs/freetype-2.2.0
+ >=media-libs/libart_lgpl-2.3.17
+ >=media-video/ffmpeg-0.4.9_p20080326
+ >=x11-libs/pango-1.14.9"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog TODO
+}