summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 13:38:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 13:38:45 +0000
commit705b1dcd47bc9928d0a1293d8207c42d40db1343 (patch)
tree8ace723a78c606c601649ab6c199ccd4e44320e7 /media-libs/x264
parentFix build with latest imagemagick, by Robin H. Johnson <robbat2@gentoo.org> (diff)
downloadgentoo-2-705b1dcd47bc9928d0a1293d8207c42d40db1343.tar.gz
gentoo-2-705b1dcd47bc9928d0a1293d8207c42d40db1343.tar.bz2
gentoo-2-705b1dcd47bc9928d0a1293d8207c42d40db1343.zip
bump a new snapshot
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/x264-0.0.20081218.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 77c6c25cb86c..172b3c26d467 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.15 2008/12/16 16:18:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.16 2008/12/19 13:38:45 aballier Exp $
+
+*x264-0.0.20081218 (19 Dec 2008)
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20081218.ebuild:
+ bump a new snapshot
16 Dec 2008; Brent Baude <ranger@gentoo.org> x264-0.0.20081006.ebuild:
Marking x264-0.0.20081006 ppc64 for bug 245285
diff --git a/media-libs/x264/x264-0.0.20081218.ebuild b/media-libs/x264/x264-0.0.20081218.ebuild
new file mode 100644
index 000000000000..fd1d810394e2
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20081218.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20081218.ebuild,v 1.1 2008/12/19 13:38:45 aballier Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib-20080406.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ "--host=${CHOST}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-encoder."
+}