summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-25 19:08:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-25 19:08:09 +0000
commit1688dc845f2ceba8fd272c62c10b2e238fa02a00 (patch)
tree3b46560a6625a59de6decbbab9df36d0a7d8343f /media-libs/yiff/yiff-2.14.5.ebuild
parentRemoved prozgui and asbutton (diff)
downloadgentoo-2-1688dc845f2ceba8fd272c62c10b2e238fa02a00.tar.gz
gentoo-2-1688dc845f2ceba8fd272c62c10b2e238fa02a00.tar.bz2
gentoo-2-1688dc845f2ceba8fd272c62c10b2e238fa02a00.zip
Fix emerging with USE="kde". Bug #146475
(Portage version: 2.1.1)
Diffstat (limited to 'media-libs/yiff/yiff-2.14.5.ebuild')
-rw-r--r--media-libs/yiff/yiff-2.14.5.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/media-libs/yiff/yiff-2.14.5.ebuild b/media-libs/yiff/yiff-2.14.5.ebuild
index 3fde331dca35..97052fd2bcab 100644
--- a/media-libs/yiff/yiff-2.14.5.ebuild
+++ b/media-libs/yiff/yiff-2.14.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.5.ebuild,v 1.2 2006/10/02 06:50:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/yiff/yiff-2.14.5.ebuild,v 1.3 2006/10/25 19:08:09 tupone Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils kde-functions
DESCRIPTION="high performance and stable sound server for UNIX games and apps"
HOMEPAGE="http://wolfpack.twu.net/YIFF/"
@@ -21,7 +21,10 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-build.patch
- use kde && sed -i '/^LIB =/s:$: -lkmid:' yiff/Makefile.Linux
+ if use kde; then
+ set-kdedir
+ sed -i "/^LIB =/s:$: -L${KDEDIR}/lib -lkmid:" yiff/Makefile.Linux
+ fi
sed -i \
-e "/^YLIB_DIR/s:/lib:/$(get_libdir):" \
-e '/LDCONFIG/s:=.*:=true:' \
@@ -32,7 +35,7 @@ src_unpack() {
src_compile() {
local pkgs="libY2 yiff yiffutils"
use gtk && pkgs="${pkgs} yiffconfig"
- use kde && append-flags -DHAVE_LIBKMID
+ use kde && append-flags -DHAVE_LIBKMID -I${KDEDIR}/include
use alsa && append-flags -DALSA_RUN_CONFORM
append-flags -DOSS -DOSS_BUFFRAG -DYSHM_SUPPORT -D__USE_BSD
emake linux \