summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-20 14:08:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-20 14:08:17 +0000
commit0f4665f7e51e3f5895291e8f4a8e193d79202036 (patch)
tree5d24f5489a3bac049c810fdfe3b21e227e58b403 /media-libs
parentmask newest media-libs/celt (diff)
downloadgentoo-2-0f4665f7e51e3f5895291e8f4a8e193d79202036.tar.gz
gentoo-2-0f4665f7e51e3f5895291e8f4a8e193d79202036.tar.bz2
gentoo-2-0f4665f7e51e3f5895291e8f4a8e193d79202036.zip
non maintainer bump, needed by ffmpeg-9999
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/celt/ChangeLog9
-rw-r--r--media-libs/celt/celt-0.11.1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/media-libs/celt/ChangeLog b/media-libs/celt/ChangeLog
index 054c04b34837..3d904e4b578a 100644
--- a/media-libs/celt/ChangeLog
+++ b/media-libs/celt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/celt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.11 2010/08/11 16:20:21 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/ChangeLog,v 1.12 2011/04/20 14:08:17 aballier Exp $
+
+*celt-0.11.1 (20 Apr 2011)
+
+ 20 Apr 2011; Alexis Ballier <aballier@gentoo.org> +celt-0.11.1.ebuild:
+ non maintainer bump, needed by ffmpeg-9999
*celt-0.8.1 (11 Aug 2010)
*celt-0.5.1.3 (11 Aug 2010)
diff --git a/media-libs/celt/celt-0.11.1.ebuild b/media-libs/celt/celt-0.11.1.ebuild
new file mode 100644
index 000000000000..75ca6170440b
--- /dev/null
+++ b/media-libs/celt/celt-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/celt/celt-0.11.1.ebuild,v 1.1 2011/04/20 14:08:17 aballier Exp $
+
+EAPI="2"
+
+DESCRIPTION="CELT is a very low delay audio codec designed for high-quality communications."
+HOMEPAGE="http://www.celt-codec.org/"
+SRC_URI="http://downloads.us.xiph.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ogg static-libs"
+
+DEPEND="ogg? ( media-libs/libogg )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ogg ogg /usr)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc README TODO || die "dodoc failed."
+
+ use static-libs || find "${D}" -name '*.la' -delete
+}