summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-02 15:20:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-02 15:20:40 +0000
commit123460238500ac93389905c02cf9b7633b3e4c8c (patch)
treece52ab05661bd1f6147e3ec7489256ac4ea3f7d2 /media-libs
parentInitial package by me. (diff)
downloadgentoo-2-123460238500ac93389905c02cf9b7633b3e4c8c.tar.gz
gentoo-2-123460238500ac93389905c02cf9b7633b3e4c8c.tar.bz2
gentoo-2-123460238500ac93389905c02cf9b7633b3e4c8c.zip
Fix buildsystem to work with modern automake, allows building with libtool-2.4.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gle/ChangeLog7
-rw-r--r--media-libs/gle/files/gle-3.1.0-autotools.patch54
-rw-r--r--media-libs/gle/gle-3.1.0-r1.ebuild7
3 files changed, 63 insertions, 5 deletions
diff --git a/media-libs/gle/ChangeLog b/media-libs/gle/ChangeLog
index 9bc138f1ca56..d0bfb0d5458d 100644
--- a/media-libs/gle/ChangeLog
+++ b/media-libs/gle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.30 2010/09/16 17:13:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/ChangeLog,v 1.31 2010/12/02 15:20:39 flameeyes Exp $
+
+ 02 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> gle-3.1.0-r1.ebuild,
+ +files/gle-3.1.0-autotools.patch:
+ Fix buildsystem to work with modern automake, allows building with
+ libtool-2.4.
16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> gle-3.0.1-r2.ebuild,
gle-3.1.0-r1.ebuild:
diff --git a/media-libs/gle/files/gle-3.1.0-autotools.patch b/media-libs/gle/files/gle-3.1.0-autotools.patch
new file mode 100644
index 000000000000..40359d85d54c
--- /dev/null
+++ b/media-libs/gle/files/gle-3.1.0-autotools.patch
@@ -0,0 +1,54 @@
+Index: gle-3.1.0/doc/Makefile.am
+===================================================================
+--- gle-3.1.0.orig/doc/Makefile.am
++++ gle-3.1.0/doc/Makefile.am
+@@ -7,5 +7,5 @@ doc_DATA = COPYING.artistic gle-3.0.lsm
+
+ EXTRA_DIST = .cvsignore COPYING.artistic gle-3.0.lsm
+
+-SUFFIXES += .lsm
++SUFFIXES = .lsm
+
+Index: gle-3.1.0/doc/html/Makefile.am
+===================================================================
+--- gle-3.1.0.orig/doc/html/Makefile.am
++++ gle-3.1.0/doc/html/Makefile.am
+@@ -87,5 +87,5 @@ doc_DATA = $(html_HTML) $(gif_HTML) $(g
+
+ EXTRA_DIST = .cvsignore $(doc_DATA)
+
+-SUFFIXES += .html .gif .jpg
++SUFFIXES = .html .gif .jpg
+
+Index: gle-3.1.0/man/Makefile.am
+===================================================================
+--- gle-3.1.0.orig/man/Makefile.am
++++ gle-3.1.0/man/Makefile.am
+@@ -22,7 +22,7 @@ EXTRA_DIST = \
+ $(man_RAW) \
+ Makefile.sgi
+
+-SUFFIXES += .man .3gle
++SUFFIXES = .man .3gle
+
+ # for the ordinary install, just copy the raw files ....
+ .man.3gle:
+@@ -38,4 +38,4 @@ SUFFIXES += .man .3gle
+ psroff -t -man < $< > $*.ps
+
+
+-CLEANFILES += $(man_MANS)
++CLEANFILES = $(man_MANS)
+Index: gle-3.1.0/src/Makefile.am
+===================================================================
+--- gle-3.1.0.orig/src/Makefile.am
++++ gle-3.1.0/src/Makefile.am
+@@ -49,7 +49,7 @@ EXTRA_DIST = \
+ INCLUDES = \
+ @X_CFLAGS@
+
+-CFLAGS = @CFLAGS@ -Wall -pedantic -Wstrict-prototypes -Wconversion
++AM_CFLAGS = -Wall -pedantic -Wstrict-prototypes -Wconversion
+
+ docdir = $(datadir)/doc/gle/
+
diff --git a/media-libs/gle/gle-3.1.0-r1.ebuild b/media-libs/gle/gle-3.1.0-r1.ebuild
index 6834332fde14..b48b93ca4401 100644
--- a/media-libs/gle/gle-3.1.0-r1.ebuild
+++ b/media-libs/gle/gle-3.1.0-r1.ebuild
@@ -1,9 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.8 2010/09/16 17:13:03 scarabeus Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="1.4"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.1.0-r1.ebuild,v 1.9 2010/12/02 15:20:39 flameeyes Exp $
inherit autotools multilib
@@ -32,6 +29,8 @@ src_unpack() {
# Don't build binary examples as they never get installed. See bug 141859
sed -i -e 's:examples::' Makefile.am
+ epatch "${FILESDIR}"/${P}-autotools.patch
+
eautoreconf
}