summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-10 22:04:46 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-10 22:04:46 +0000
commit1de47070db26e20ca891df4e906785135ce52e08 (patch)
treee780bce95600d6a664e2f590ceb6a6b79395303e /media-libs
parentBump to current snapshot #101431 (diff)
downloadgentoo-2-1de47070db26e20ca891df4e906785135ce52e08.tar.gz
gentoo-2-1de47070db26e20ca891df4e906785135ce52e08.tar.bz2
gentoo-2-1de47070db26e20ca891df4e906785135ce52e08.zip
Add makedepend-location.patch to stop mesa from looking in /usr/X11R6/bin.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/files/makedepend-location.patch12
-rw-r--r--media-libs/mesa/mesa-6.3.1.1.ebuild3
3 files changed, 19 insertions, 2 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 4cfb3d93f282..3e64092cb6e9 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.16 2005/08/10 21:36:40 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.17 2005/08/10 22:04:46 spyderous Exp $
+
+ 10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/makedepend-location.patch, mesa-6.3.1.1.ebuild:
+ Add makedepend-location.patch to stop mesa from looking in /usr/X11R6/bin.
10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.3.1.1.ebuild:
Add dep on >=x11-proto/glproto-1.4-r1.
diff --git a/media-libs/mesa/files/makedepend-location.patch b/media-libs/mesa/files/makedepend-location.patch
new file mode 100644
index 000000000000..7e49deec5632
--- /dev/null
+++ b/media-libs/mesa/files/makedepend-location.patch
@@ -0,0 +1,12 @@
+diff -urN Mesa-6.3.1.1.orig/configs/linux-dri Mesa-6.3.1.1/configs/linux-dri
+--- Mesa-6.3.1.1.orig/configs/linux-dri 2005-07-23 23:29:14.000000000 -0700
++++ Mesa-6.3.1.1/configs/linux-dri 2005-08-10 14:56:16.000000000 -0700
+@@ -9,7 +9,7 @@
+ CC = gcc
+ CXX = g++
+
+-MKDEP = /usr/X11R6/bin/makedepend
++MKDEP = /usr/bin/makedepend
+ #MKDEP = gcc -M
+ #MKDEP_OPTIONS = -MF depend
+
diff --git a/media-libs/mesa/mesa-6.3.1.1.ebuild b/media-libs/mesa/mesa-6.3.1.1.ebuild
index 8998f7ddab27..cb2d6f86db90 100644
--- a/media-libs/mesa/mesa-6.3.1.1.ebuild
+++ b/media-libs/mesa/mesa-6.3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.1.1.ebuild,v 1.7 2005/08/10 21:36:40 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.3.1.1.ebuild,v 1.8 2005/08/10 22:04:46 spyderous Exp $
inherit eutils toolchain-funcs
@@ -60,6 +60,7 @@ src_unpack() {
epatch ${FILESDIR}/fix-xthreads-location.patch
epatch ${FILESDIR}/use-xthreads.patch
+ epatch ${FILESDIR}/makedepend-location.patch
# Set up linux-dri configs
echo "OPT_FLAGS = ${CFLAGS}" >> ${HOSTCONF}