summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-07 05:58:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-07 05:58:39 +0000
commit2d9f3121d18a7a0d6e31121dc0d4f0ea9323c26a (patch)
tree5f18ffb1f0df4bca35aaae6fa202d670d7a22b02 /media-libs
parentMask new x264 snapshot (diff)
downloadgentoo-2-2d9f3121d18a7a0d6e31121dc0d4f0ea9323c26a.tar.gz
gentoo-2-2d9f3121d18a7a0d6e31121dc0d4f0ea9323c26a.tar.bz2
gentoo-2-2d9f3121d18a7a0d6e31121dc0d4f0ea9323c26a.zip
Add new snapshot
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/x264-0.0.20081006.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index adbb6ddf880c..54d9ebcedd94 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.5 2008/08/22 11:27:29 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.6 2008/10/07 05:58:39 aballier Exp $
+
+*x264-0.0.20081006 (07 Oct 2008)
+
+ 07 Oct 2008; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20081006.ebuild:
+ Add new snapshot
*x264-0.0.20080819 (22 Aug 2008)
diff --git a/media-libs/x264/x264-0.0.20081006.ebuild b/media-libs/x264/x264-0.0.20081006.ebuild
new file mode 100644
index 000000000000..e5917ef2b531
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20081006.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20081006.ebuild,v 1.1 2008/10/07 05:58:39 aballier Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib-20080406.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-encoder."
+}