summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-24 21:55:47 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-08-24 21:55:47 +0000
commit2dd2207ce06378050aef727f6c4a94f75b0328ad (patch)
treeb22369235bf86ce2f2946bd7ec796088dffbfaea /media-libs
parentNew package, will be needed for gnome-3.6. Thanks to Frédéric Romagné for ... (diff)
downloadgentoo-2-2dd2207ce06378050aef727f6c4a94f75b0328ad.tar.gz
gentoo-2-2dd2207ce06378050aef727f6c4a94f75b0328ad.tar.bz2
gentoo-2-2dd2207ce06378050aef727f6c4a94f75b0328ad.zip
Add patch from OpenSuSE to get rid of an implicit function declaration, bug 430372
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lcms/ChangeLog7
-rw-r--r--media-libs/lcms/files/lcms-1.19-implicit.patch49
-rw-r--r--media-libs/lcms/lcms-1.19.ebuild3
3 files changed, 57 insertions, 2 deletions
diff --git a/media-libs/lcms/ChangeLog b/media-libs/lcms/ChangeLog
index 664abfdabc91..f86757440d47 100644
--- a/media-libs/lcms/ChangeLog
+++ b/media-libs/lcms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lcms
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/ChangeLog,v 1.145 2012/08/22 02:33:56 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/ChangeLog,v 1.146 2012/08/24 21:55:47 dilfridge Exp $
+
+ 24 Aug 2012; Andreas K. Huettel <dilfridge@gentoo.org> lcms-1.19.ebuild,
+ +files/lcms-1.19-implicit.patch:
+ Add patch from OpenSuSE to get rid of an implicit function declaration, bug
+ 430372
22 Aug 2012; Christoph Junghans <ottxor@gentoo.org> lcms-2.3.ebuild:
added prefix keywords
diff --git a/media-libs/lcms/files/lcms-1.19-implicit.patch b/media-libs/lcms/files/lcms-1.19-implicit.patch
new file mode 100644
index 000000000000..076ed15be794
--- /dev/null
+++ b/media-libs/lcms/files/lcms-1.19-implicit.patch
@@ -0,0 +1,49 @@
+cmsio1.c: In function 'AdjustEndianessArray16':
+cmsio1.c:118: warning: implicit declaration of function 'swab'
+testcms.c: In function 'CheckSwab':
+testcms.c:113: warning: implicit declaration of function 'swab'
+================================================================================
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -6,6 +6,9 @@
+ # Don't require all the GNU mandated files
+ AUTOMAKE_OPTIONS = 1.7 foreign
+
++# _XOPEN_SOURCE is required for swab() but undefines strcasecmp(), so add _GNU_SOURCE as well:
++AM_CPPFLAGS = -D_XOPEN_SOURCE -D_GNU_SOURCE
++
+ includedir = ${prefix}/include
+
+ # Shared libraries built in this directory
+--- src/cmsio1.c
++++ src/cmsio1.c
+@@ -24,6 +24,7 @@
+
+
+ #include "lcms.h"
++#include <unistd.h>
+
+ // ----------------------------------------------------------------- Tag Serialization
+
+--- testbed/Makefile.am
++++ testbed/Makefile.am
+@@ -6,6 +6,9 @@
+ # Don't require all the GNU mandated files
+ AUTOMAKE_OPTIONS = 1.7 foreign
+
++# Required for swab()
++AM_CPPFLAGS = -D_XOPEN_SOURCE
++
+ INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
+
+ check_PROGRAMS = testcms
+--- testbed/testcms.c
++++ testbed/testcms.c
+@@ -36,6 +36,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #ifndef NON_WINDOWS
+ #include <icm.h>
diff --git a/media-libs/lcms/lcms-1.19.ebuild b/media-libs/lcms/lcms-1.19.ebuild
index beb417b3df31..01016a393fcb 100644
--- a/media-libs/lcms/lcms-1.19.ebuild
+++ b/media-libs/lcms/lcms-1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/lcms-1.19.ebuild,v 1.13 2012/04/26 20:40:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/lcms-1.19.ebuild,v 1.14 2012/08/24 21:55:47 dilfridge Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -35,6 +35,7 @@ src_prepare() {
sed -e "/SUBDIRS =/s/ python//" -i Makefile.am
epatch "${FILESDIR}/${P}-disable_static_modules.patch"
+ epatch "${FILESDIR}/${P}-implicit.patch"
eautoreconf