summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-09-05 12:27:54 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-09-05 12:27:54 +0000
commit2e1f0f9116725fe5ef625ef50662b7bffda79050 (patch)
tree2dd3836c4ec337f52ac7717074840a104fcfcf6b /media-libs
parentFixed keywords. (diff)
downloadgentoo-2-2e1f0f9116725fe5ef625ef50662b7bffda79050.tar.gz
gentoo-2-2e1f0f9116725fe5ef625ef50662b7bffda79050.tar.bz2
gentoo-2-2e1f0f9116725fe5ef625ef50662b7bffda79050.zip
Version bump from project overlay
(Portage version: 2.1.3.7)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/pdflib/ChangeLog11
-rw-r--r--media-libs/pdflib/files/digest-pdflib-7.0.23
-rw-r--r--media-libs/pdflib/pdflib-7.0.2.ebuild118
3 files changed, 131 insertions, 1 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index e2bd9c506f10..990b4fc4fbd2 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.81 2007/08/06 13:38:27 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.82 2007/09/05 12:27:54 jokey Exp $
+
+*pdflib-7.0.2 (05 Sep 2007)
+
+ 05 Sep 2007; Markus Ullmann <jokey@gentoo.org> +pdflib-7.0.2.ebuild:
+ Version bump from project overlay
+
+ 03 Sep 2007; Jakub Moc <jakub@gentoo.org> +pdflib-7.0.2.ebuild
+ Version bump; use perl-module and python eclasses properly and get rid of
+ the nasty hacks, fix inherits, other cleanups
06 Aug 2007; Gustavo Zacarias <gustavoz@gentoo.org> pdflib-7.0.1.ebuild:
Stable on sparc
diff --git a/media-libs/pdflib/files/digest-pdflib-7.0.2 b/media-libs/pdflib/files/digest-pdflib-7.0.2
new file mode 100644
index 000000000000..bb6bc9cdcbdd
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-7.0.2
@@ -0,0 +1,3 @@
+MD5 0d3410cfacdd6cc80dd2e89770f5a40d PDFlib-Lite-7.0.2.tar.gz 5478372
+RMD160 098d2950f01789eadbdf49c048eac4e740ad8cd7 PDFlib-Lite-7.0.2.tar.gz 5478372
+SHA256 4292bfb2d02915897596099779021d99a4819098fe56bcffb00ecf183f3907f7 PDFlib-Lite-7.0.2.tar.gz 5478372
diff --git a/media-libs/pdflib/pdflib-7.0.2.ebuild b/media-libs/pdflib/pdflib-7.0.2.ebuild
new file mode 100644
index 000000000000..63861a22ea74
--- /dev/null
+++ b/media-libs/pdflib/pdflib-7.0.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-7.0.2.ebuild,v 1.1 2007/09/05 12:27:54 jokey Exp $
+
+inherit java-pkg-opt-2 flag-o-matic libtool python perl-module multilib
+
+MY_PN="${PN/pdf/PDF}-Lite"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A library for generating PDF on the fly."
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/binaries/${PN/pdf/PDF}/${PV//./}/${MY_P}.tar.gz"
+LICENSE="PDFLite"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc java perl python tcl"
+
+COMMON_DEP="tcl? ( >=dev-lang/tcl-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( >=dev-lang/python-2.2 )"
+
+DEPEND="${COMMON_DEP}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="
+ ${COMMON_DEP}
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+
+ # Bug #87004
+ filter-flags -mcpu=*
+ filter-flags -mtune=*
+
+ append-ldflags -Wl,-z,noexecstack
+
+ # Necessary for multilib on amd64. Please keep this in future releases.
+ # BUG #81197
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/02/14
+ if use tcl ; then
+ TCLVER="$(echo 'puts [info tclversion]' | $(type -P tclsh))"
+ myconf="--with-tclpkg=/usr/$(get_libdir)/tcl${TCLVER}/"
+ else
+ myconf="--with-tcl=no"
+ fi
+ use perl || myconf="${myconf} --with-perl=no"
+ if use python ; then
+ python_version
+ myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}"
+ else
+ myconf="${myconf} --with-py=no"
+ fi
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ econf --enable-cxx ${myconf}
+
+ if use java; then
+ JAVACFLAGS="$(java-pkg_javac-args)" emake || die "emake failed"
+ if use doc; then
+ cd ./bind/pdflib/java || die
+ emake javadoc || die "Failed to generate javadoc"
+ fi
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ for binding in perl python tcl ; do
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/${binding}/Makefile" \
+ || die "sed bind/pdflib/${binding}/Makefile failed"
+ done
+
+ # this should create the correct lib dirs for perl and python.
+ if use python ; then
+ python_version
+ dodir /usr/$(get_libdir)/python${PYVER}/lib-dynload
+ fi
+ if use perl ; then
+ perlinfo
+ dodir ${SITE_ARCH}
+ fi
+
+ # next line required for proper install
+ dodir /usr/bin
+ einstall || die
+
+ dodoc readme.txt doc/*
+ docinto pdflib
+ dodoc doc/pdflib/*
+
+ # seemant: seems like the makefiles for pdflib generate the .jar file anyway
+ use java && java-pkg_dojar bind/pdflib/java/pdflib.jar
+ if use java && use doc; then
+ java-pkg_dojavadoc ./bind/pdflib/java/javadoc
+ fi
+}
+
+pkg_postinst() {
+ if has_version "<media-libs/pdflib-7.0.1" ; then
+ ewarn "Please run revdep-rebuild now! All packages that linked with"
+ ewarn "previous versions of PDFLib will no longer work unless you"
+ ewarn "run it."
+ fi
+}