summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-18 07:18:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-18 07:18:36 +0000
commit3697da876e2382c68232cf158ede221b33c15741 (patch)
tree8f1cb6a2c456d9eff75f8b1841b20784e43512fa /media-libs
parentRemove old (diff)
downloadgentoo-2-3697da876e2382c68232cf158ede221b33c15741.tar.gz
gentoo-2-3697da876e2382c68232cf158ede221b33c15741.tar.bz2
gentoo-2-3697da876e2382c68232cf158ede221b33c15741.zip
Initial Addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/pymemphis/ChangeLog10
-rw-r--r--media-libs/pymemphis/metadata.xml7
-rw-r--r--media-libs/pymemphis/pymemphis-0.2.1.ebuild44
3 files changed, 61 insertions, 0 deletions
diff --git a/media-libs/pymemphis/ChangeLog b/media-libs/pymemphis/ChangeLog
new file mode 100644
index 000000000000..2777727fdeb6
--- /dev/null
+++ b/media-libs/pymemphis/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/pymemphis
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pymemphis/ChangeLog,v 1.1 2010/06/18 07:18:36 jlec Exp $
+
+*pymemphis-0.2.1 (18 Jun 2010)
+
+ 18 Jun 2010; Justin Lecher <jlec@gentoo.org> +pymemphis-0.2.1.ebuild,
+ +metadata.xml:
+ Initial Addition
+
diff --git a/media-libs/pymemphis/metadata.xml b/media-libs/pymemphis/metadata.xml
new file mode 100644
index 000000000000..c7027aef1522
--- /dev/null
+++ b/media-libs/pymemphis/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-libs/pymemphis/pymemphis-0.2.1.ebuild b/media-libs/pymemphis/pymemphis-0.2.1.ebuild
new file mode 100644
index 000000000000..2a57484f223a
--- /dev/null
+++ b/media-libs/pymemphis/pymemphis-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pymemphis/pymemphis-0.2.1.ebuild,v 1.1 2010/06/18 07:18:36 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+AT_M4DIR="build/autotools/"
+
+inherit autotools python
+
+DESCRIPTION="Python bindings for the libmemphis library"
+HOMEPAGE="http://gitorious.net/pymemphis"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+RDEPEND="
+ dev-python/pycairo
+ dev-python/pygobject
+ media-libs/memphis"
+DEPEND="${RDEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${PN}-mainline
+
+src_prepare() {
+ eautoreconf
+ echo "#!${EPREFIX}/bin/sh" > py-compile
+ sed 's:0.1:0.2:g' -i pymemphis.pc.in || die
+ python_src_prepare
+}
+
+src_install() {
+ python_execute_function -s -d
+ find "${ED}" -name "*.la" -delete || die
+ dodoc AUTHORS ChangeLog README || die
+}