summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-16 22:47:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-16 22:47:39 +0000
commit41eea9cb9a820b8a0f4df1dfd8b0133067d99a71 (patch)
tree51412bbc118f44c32a238844d8f6f5bec66e355c /media-libs
parentadd comments (diff)
downloadgentoo-2-41eea9cb9a820b8a0f4df1dfd8b0133067d99a71.tar.gz
gentoo-2-41eea9cb9a820b8a0f4df1dfd8b0133067d99a71.tar.bz2
gentoo-2-41eea9cb9a820b8a0f4df1dfd8b0133067d99a71.zip
make ebuild suck less
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openexr/openexr-1.2.2.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/media-libs/openexr/openexr-1.2.2.ebuild b/media-libs/openexr/openexr-1.2.2.ebuild
index bbdc0c49d77e..903d791b4070 100644
--- a/media-libs/openexr/openexr-1.2.2.ebuild
+++ b/media-libs/openexr/openexr-1.2.2.ebuild
@@ -1,25 +1,26 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr/openexr-1.2.2.ebuild,v 1.3 2005/05/09 14:15:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr/openexr-1.2.2.ebuild,v 1.4 2005/06/16 22:47:39 vapier Exp $
MY_P=OpenEXR-${PV}
S=${WORKDIR}/${MY_P}
DESCRIPTION="ILM's HDR image file format libraries"
+HOMEPAGE="http://www.openexr.com/"
SRC_URI="http://savannah.nongnu.org/download/openexr/${MY_P}.tar.gz"
-HOMEPAGE="http://www.openexr.com"
-SLOT="0"
LICENSE="as-is"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~ppc64 ~ia64"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
DEPEND="x11-libs/fltk"
src_unpack() {
unpack ${A}
- sed -i -e "s:OpenEXR-@OPENEXR_VERSION@:\$\(P\):" ${S}/IlmImfExamples/Makefile.in
- sed -i -e "s:NVSDK_CXXFLAGS=\"\":NVSDK_CXXFLAGS=\"-DUNIX\":" ${S}/acinclude.m4
+ sed -i \
+ -e "/^examplesdir/s:OpenEXR-@OPENEXR_VERSION@:${P}:" \
+ "${S}"/IlmImfExamples/Makefile.in || die
}
src_compile() {
@@ -29,9 +30,9 @@ src_compile() {
emake || die "make failed"
}
-src_install () {
- einstall || die "install failed"
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS README INSTALL ChangeLog LICENSE NEWS
- use doc && dohtml -r ${S}/doc/*
+ dodoc AUTHORS README INSTALL ChangeLog NEWS
+ use doc && dohtml -r "${S}"/doc/*
}