summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-29 20:08:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-29 20:08:52 +0000
commit435d154a9ead4ae26749c7a42e971442664b2666 (patch)
treefa3838a75c573a084d177444a414d94a0f3c37af /media-libs
parentBump version, bug 141986. (diff)
downloadgentoo-2-435d154a9ead4ae26749c7a42e971442664b2666.tar.gz
gentoo-2-435d154a9ead4ae26749c7a42e971442664b2666.tar.bz2
gentoo-2-435d154a9ead4ae26749c7a42e971442664b2666.zip
Apply patch to fix NULL pointer dereference when using dmix settings in asound.conf. Thanks to Adrian von Buttlar for reporting in bug #142111.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/ChangeLog10
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.12_rc1-r1.ebuild71
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-1.0.12_rc1-bindings-crash.patch12
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1-r13
4 files changed, 95 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index e5646f69e9c3..7dbc0ea3bce3 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.177 2006/07/21 01:35:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.178 2006/07/29 20:08:52 flameeyes Exp $
+
+*alsa-lib-1.0.12_rc1-r1 (29 Jul 2006)
+
+ 29 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-lib-1.0.12_rc1-bindings-crash.patch,
+ +alsa-lib-1.0.12_rc1-r1.ebuild:
+ Apply patch to fix NULL pointer dereference when using dmix settings in
+ asound.conf. Thanks to Adrian von Buttlar for reporting in bug #142111.
21 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-lib-1.0.11-r1.ebuild, alsa-lib-1.0.12_rc1.ebuild:
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.12_rc1-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.12_rc1-r1.ebuild
new file mode 100644
index 000000000000..3eac6b93f193
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.12_rc1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.12_rc1-r1.ebuild,v 1.1 2006/07/29 20:08:52 flameeyes Exp $
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.10_rc3-hardened.patch"
+ epatch "${FILESDIR}/${PN}-1.0.10-no-wordexp-header.patch"
+ epatch "${FILESDIR}/${P}-bindings-crash.patch"
+
+ eautomake
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ einfo ""
+ einfo "Please try media-sound/alsa-driver before filing bugs about unstable"
+ einfo "or missing output with in-kernel drivers. Misaligned versions of"
+ einfo "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/alsa-lib-1.0.12_rc1-bindings-crash.patch b/media-libs/alsa-lib/files/alsa-lib-1.0.12_rc1-bindings-crash.patch
new file mode 100644
index 000000000000..94d8c3a5dff1
--- /dev/null
+++ b/media-libs/alsa-lib/files/alsa-lib-1.0.12_rc1-bindings-crash.patch
@@ -0,0 +1,12 @@
+--- src/pcm/pcm_direct.c 2006-06-21 17:31:59.000000000 +0200
++++ src/pcm/pcm_direct.c 2006-07-29 21:04:11.542194680 +0200
+@@ -1392,7 +1394,8 @@
+ }
+ bindings[cchannel] = schannel;
+ }
+- if (dmix->type == SND_PCM_TYPE_DSNOOP)
++ if (dmix->type == SND_PCM_TYPE_DSNOOP ||
++ ! dmix->bindings)
+ goto __skip_same_dst;
+ for (chn = 0; chn < count; chn++) {
+ for (chn1 = 0; chn1 < count; chn1++) {
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1-r1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1-r1
new file mode 100644
index 000000000000..2fb0d4246015
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.12_rc1-r1
@@ -0,0 +1,3 @@
+MD5 8a3f6d218a9285426556fb3006054725 alsa-lib-1.0.12rc1.tar.bz2 705338
+RMD160 9e235fdcee54fb9c1b98218d93590b16a59675e6 alsa-lib-1.0.12rc1.tar.bz2 705338
+SHA256 f7fb1855610c33cbfc362fce5b130fef634f614e99616c4a99d8cf33758d2eea alsa-lib-1.0.12rc1.tar.bz2 705338