summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-04 08:29:22 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-04 08:29:22 +0000
commit43d4f856d02163fc99dbbd6332f6d2cc34a2798b (patch)
treea436b6098c7f6d658cc1dbd10e1e93d99511d6cc /media-libs
parentadd name to changelog entry (diff)
downloadgentoo-2-43d4f856d02163fc99dbbd6332f6d2cc34a2798b.tar.gz
gentoo-2-43d4f856d02163fc99dbbd6332f6d2cc34a2798b.tar.bz2
gentoo-2-43d4f856d02163fc99dbbd6332f6d2cc34a2798b.zip
Version bump. Add static-libs USE flag.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libraw/ChangeLog8
-rw-r--r--media-libs/libraw/files/libraw-0.13.6-makefile.patch59
-rw-r--r--media-libs/libraw/libraw-0.13.6.ebuild60
3 files changed, 126 insertions, 1 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index e2943159e5da..2414a2a216e0 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.5 2011/05/23 21:55:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.6 2011/07/04 08:29:22 radhermit Exp $
+
+*libraw-0.13.6 (04 Jul 2011)
+
+ 04 Jul 2011; Tim Harder <radhermit@gentoo.org> +libraw-0.13.6.ebuild,
+ +files/libraw-0.13.6-makefile.patch:
+ Version bump. Add static-libs USE flag.
*libraw-0.13.5 (23 May 2011)
diff --git a/media-libs/libraw/files/libraw-0.13.6-makefile.patch b/media-libs/libraw/files/libraw-0.13.6-makefile.patch
new file mode 100644
index 000000000000..2ae4e9af8887
--- /dev/null
+++ b/media-libs/libraw/files/libraw-0.13.6-makefile.patch
@@ -0,0 +1,59 @@
+--- LibRaw-0.13.6/Makefile.am.orig
++++ LibRaw-0.13.6/Makefile.am
+@@ -26,7 +26,6 @@
+ pkgconfig_DATA = libraw.pc libraw_r.pc
+
+ # Libraries
+-lib_LIBRARIES = lib/libraw.a lib/libraw_r.a
+ lib_LTLIBRARIES = lib/libraw.la lib/libraw_r.la
+
+ lib_libraw_a_CPPFLAGS = -DLIBRAW_NOTHREADS -w
+@@ -60,40 +59,32 @@
+
+ bin_raw_identify_SOURCES = samples/raw-identify.cpp
+ bin_raw_identify_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_raw_identify_LDADD = -Llib/ -lraw
+-bin_raw_identify_DEPENDENCIES = lib/libraw.a
++bin_raw_identify_LDADD = lib/libraw.la
+
+ bin_unprocessed_raw_SOURCES = samples/unprocessed_raw.cpp
+ bin_unprocessed_raw_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_unprocessed_raw_LDADD = -Llib/ -lraw
+-bin_unprocessed_raw_DEPENDENCIES = lib/libraw.a
++bin_unprocessed_raw_LDADD = lib/libraw.la
+
+ bin_4channels_SOURCES = samples/4channels.cpp
+ bin_4channels_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_4channels_LDADD = -Llib/ -lraw
+-bin_4channels_DEPENDENCIES = lib/libraw.a
++bin_4channels_LDADD = lib/libraw.la
+
+ bin_simple_dcraw_SOURCES = samples/simple_dcraw.cpp
+ bin_simple_dcraw_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_simple_dcraw_LDADD = -Llib/ -lraw
+-bin_simple_dcraw_DEPENDENCIES = lib/libraw.a
++bin_simple_dcraw_LDADD = lib/libraw.la
+
+ bin_mem_image_SOURCES = samples/mem_image.cpp
+ bin_mem_image_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_mem_image_LDADD = -Llib/ -lraw
+-bin_mem_image_DEPENDENCIES = lib/libraw.a
++bin_mem_image_LDADD = lib/libraw.la
+
+ bin_dcraw_half_SOURCES = samples/dcraw_half.c
+ bin_dcraw_half_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_dcraw_half_LDADD = -Llib/ -lraw
+-bin_dcraw_half_DEPENDENCIES = lib/libraw.a
++bin_dcraw_half_LDADD = lib/libraw.la
+
+ bin_half_mt_SOURCES = samples/half_mt.c
+ bin_half_mt_CFLAGS = $(lib_libraw_r_a_CXXFLAGS)
+-bin_half_mt_LDADD = -Llib/ -lraw_r
+-bin_half_mt_DEPENDENCIES = lib/libraw_r.a
++bin_half_mt_LDADD = lib/libraw_r.la
+
+ bin_dcraw_emu_SOURCES = samples/dcraw_emu.cpp
+ bin_dcraw_emu_CPPFLAGS = $(lib_libraw_a_CPPFLAGS)
+-bin_dcraw_emu_LDADD = -Llib/ -lraw
+-bin_dcraw_emu_DEPENDENCIES = lib/libraw.a
++bin_dcraw_emu_LDADD = lib/libraw.la
diff --git a/media-libs/libraw/libraw-0.13.6.ebuild b/media-libs/libraw/libraw-0.13.6.ebuild
new file mode 100644
index 000000000000..0eff4373d01c
--- /dev/null
+++ b/media-libs/libraw/libraw-0.13.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.13.6.ebuild,v 1.1 2011/07/04 08:29:22 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+MY_P="LibRaw-${PV}"
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.libraw.org/data/${MY_P}.tar.gz
+ demosaic? ( https://github.com/LibRaw/LibRaw-demosaic-pack-GPL2/tarball/${PV} -> LibRaw-demosaic-pack-GPL2-${PV}.tar.gz
+ https://github.com/LibRaw/LibRaw-demosaic-pack-GPL3/tarball/${PV} -> LibRaw-demosaic-pack-GPL3-${PV}.tar.gz )"
+
+# Libraw also has it's own license, which is a pdf file and
+# can be obtained from here:
+# http://www.libraw.org/data/LICENSE.LibRaw.pdf
+LICENSE="LGPL-2.1 CDDL GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="demosaic examples +lcms +openmp static-libs"
+
+DEPEND="lcms? ( media-libs/lcms:2 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( Changelog.txt README )
+
+src_unpack() {
+ unpack ${A}
+ if use demosaic ; then
+ mv *LibRaw-demosaic*GPL2* LibRaw-demosaic-pack-GPL2-${PV}
+ mv *LibRaw-demosaic*GPL3* LibRaw-demosaic-pack-GPL3-${PV}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+ eautomake
+}
+
+src_configure() {
+ econf \
+ $(use_enable demosaic demosaic-pack-gpl2) \
+ $(use_enable demosaic demosaic-pack-gpl3) \
+ $(use_enable examples) \
+ $(use_enable lcms) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove useless .la files
+ find "${D}" -name '*.la' -exec rm -f {} +
+}